Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
31 user(s) are online (16 user(s) are browsing Forum)

Members: 0
Guests: 31

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +5€

Current balance: -45€
(last updated 09/2019)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 52 users playing Freelancer on 41 servers.
October. 17, 2019

Browsing this Thread:   1 Anonymous Users



 Bottom   Previous Topic   Next Topic  Register To Post

« 1 (2)


Re: Cutscene audio & video out of sync

Joined:
2014/9/3 16:39
Group:
Registered Users
Posts: 27
Offline
No, all the files are playing normally in every audio player I have. Everything is normal: every other piece of media and video game on my hard drive works normally. The only problems are with the following Freelancer cutscenes: s010x, s019a, s019b, s027xb, s051xa, s051xb, s069x and s072ab.

I've tried converting the files to PCM, it made no difference. As for the MP3 codecs, I have Fraunhofer, Lame, and have now installed Fraunhofer Professional.

I don't know my way around Command Prompt that good, so can you explain that part with a bit more detail?

Posted on: 2015/8/25 14:24
Top
Re: Cutscene audio & video out of sync
Home away from home
Joined:
2009/8/16 2:58
From Qld, Aus.
Group:
Registered Users
FLServer Admins
Trusted Speciality Developers
Senior Members
Posts: 1909
Offline
Use this to try out LAME (adjust paths to suit, of course; press TAB to "complete" the names):

Code:
C:\Users\Jason>cd \Games\Freelancer\EXE

C:\Games\Freelancer\EXE>set FL_MP3=Lame ACM MP3 Codec

C:\Games\Freelancer\EXE>Freelancer.exe

That's all, not terribly complicated. Still, if using PCM didn't have an effect, I don't see this making a difference, either. The only other thing I can think to do is chop up the mixes into 30 second chunks and adjust the scripts accordingly - hardly worth the effort. But if you're really that keen, you do the chopping and I'll do the adjusting...

Posted on: 2015/8/25 15:16
Top
Re: Cutscene audio & video out of sync

Joined:
2014/9/3 16:39
Group:
Registered Users
Posts: 27
Offline
Yep, you're right. It didn't make any difference. Ah well, it looks like I'll have to learn to live with it.

Thanks for all your help adoxa.

Posted on: 2015/8/26 9:54
Top
Re: Cutscene audio & video out of sync
Home away from home
Joined:
2009/8/16 2:58
From Qld, Aus.
Group:
Registered Users
FLServer Admins
Trusted Speciality Developers
Senior Members
Posts: 1909
Offline
If you're willing, give it one more try: resample the audio to slow it down. In FFmpeg it's:
Code:
ffmpeg -i mix_s019a.bak -af asetrate=21805 mix_s019a.wav

I think that will add an extra second every 90 seconds, since you said you were two seconds ahead on the 3-minute Lonnigan scene - 178/180 * 22050 = 21805.

Posted on: 2015/8/27 9:45
Top
Re: Cutscene audio & video out of sync

Joined:
2014/9/3 16:39
Group:
Registered Users
Posts: 27
Offline
I tested it with mix_s019b, but now it varies wildly, First the audio is a little bit faster, but barely noticeable, and in the end the video is much much faster than the audio.

Posted on: 2015/8/27 10:16
Top
« 1 (2)