Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
48 user(s) are online (21 user(s) are browsing Forum)

Members: 0
Guests: 48

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +30€

Current balance: -190€
(last updated 04/2017)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 64 users playing Freelancer on 34 servers.
October. 22, 2017

Browsing this Thread:   1 Anonymous Users



 Bottom   Previous Topic   Next Topic  Register To Post



Killing server due to no flhook response
Not too shy to talk
Joined:
2012/8/29 12:51
Group:
Registered Users
Posts: 69
Offline
It just started looping this morning. Nothing was changed. No settings. Any ideas?

Posted on: 2015/11/30 14:36
Top
Re: Killing server due to no flhook response
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 310
Offline
If I get u right... your server doesn´t start properly due to flhook can´t "plug in" in the "flserver-process"...
I´d recommend to fire up flserver once without FlHook... just to find out if its just hook related in the first place. After that you could do some more specific investigations.


But these are just my two cents...

Greetings


Edit: Is there the possibility that your server got hacked or "ddos"-ed?

Posted on: 2015/11/30 16:11
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Re: Killing server due to no flhook response
Not too shy to talk
Joined:
2012/8/29 12:51
Group:
Registered Users
Posts: 69
Offline
Not sure.When I start it with just the flserver.exe it stays up but I cannot log into the server. connection cannot be established to that server. I can connect to other server. As far as hacked, maybe. I just got rid of a player yesterday who bragged about his coding skills. DDOS?...I can access the internet no problem and play on other servers so it seems unlikely. I reinstalled all the files and still no good.

Posted on: 2015/11/30 16:43
Top
Re: Killing server due to no flhook response
Not too shy to talk
Joined:
2012/8/29 12:51
Group:
Registered Users
Posts: 69
Offline
It comes up new socket connection ascii 127.0.0.1:3079. tHEN RESTARTS. Google points towards .net. Any ideas? I'll work on it more after Dr. Appt. Thanks.

Posted on: 2015/11/30 16:53
Top
Re: Killing server due to no flhook response
Starport Admin
Joined:
2009/2/21 21:42
Group:
Webmasters
Registered Users
Posts: 3447
Offline
There are FL-specific DDOS that will not otherwise affect your internet.

http://the-starport.net/modules/newbb ... php?topic_id=400&forum=11

Posted on: 2015/11/30 19:10
"Cynicism is not realistic and tough. It's unrealistic and kind of cowardly because it means you don't have to try."
-Peggy Noonan
Top
Re: Killing server due to no flhook response
Not too shy to talk
Joined:
2012/8/29 12:51
Group:
Registered Users
Posts: 69
Offline
I reinstalled . net....didn't work. I added the anti-ddos per instructions....no good. still looping.

Posted on: 2015/11/30 20:12
Top
Re: Killing server due to no flhook response
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 310
Offline
Just to help you by eliminating possibilties:

Did you already make sure it isn´t caused by a corrupt/hacked/modified Playerfile ?
Got a "similar" problem a while ago... Deleted all players testwise and... BINGO !!!

To make things clear:
I´M NO PRO IN THIS... just trying to come up with some ideas, ´cause I experienced a lot of "brain-blocks" myself when it comes to ERROR-CHECKING/FINDING...


Best wishes

J.R.

Posted on: 2015/11/30 20:26
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Re: Killing server due to no flhook response
Not too shy to talk
Joined:
2012/8/29 12:51
Group:
Registered Users
Posts: 69
Offline
Nope. deleted all player files. No good. still looping.

Posted on: 2015/11/30 20:44
Top
Re: Killing server due to no flhook response
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 310
Offline
Damn.... I´m running out of options...
Just to be more specific: Did you re-setup the server completely?
Meaning to delete the .cfg and everything else in Accts/Multiplayer-Folder...
If so... I think me is not able to help you any further... i´m terribly sorry mate.
But maybe some of our coding-gods here is able to do so.


Best regards


J.R.

Posted on: 2015/11/30 20:52
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Re: Killing server due to no flhook response
Not too shy to talk
Joined:
2012/8/29 12:51
Group:
Registered Users
Posts: 69
Offline
Yes. Unistalled the game and reinstalled, I'm going to check TWC and see if there's incoming traffic. My router isn't showing anything but I might be looking at it wrong.

Posted on: 2015/11/30 20:58
Top
Re: Killing server due to no flhook response
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 310
Offline
The thing that makes me wonder the most is the connect-problem (assuming your Router-settings are correct regarding forwarding Ports and such) even when you fire up the server without the "looping" hook.

Since you said you´re not able to even connect (assuming "your" client is in LAN with the server)
THIS is more than STRANGE to me....

As I said... I´m running out of options...

Posted on: 2015/11/30 21:06
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Re: Killing server due to no flhook response
Not too shy to talk
Joined:
2012/8/29 12:51
Group:
Registered Users
Posts: 69
Offline
I cannot connect to it even in LAN. The settings were fine until I banned a player who bragged about his coding skills. TWC said the IP was being redirected and they fixed the redirect but I'm still not able to get past the flhook failure.

Posted on: 2015/11/30 21:45
Top
Re: Killing server due to no flhook response
Not too shy to talk
Joined:
2012/8/29 12:51
Group:
Registered Users
Posts: 69
Offline
I cannot connect to it even in LAN. The settings were fine until I banned a player who bragged about his coding skills. TWC said the IP was being redirected and they fixed the redirect but I'm still not able to get past the flhook failure.

Posted on: 2015/11/30 22:58
Top
Re: Killing server due to no flhook response
Not too shy to talk
Joined:
2012/8/29 12:51
Group:
Registered Users
Posts: 69
Offline
OK. TWC said my IP was being redirected and under DDOS. They said it'll take 15 days at most for new IP. Whover has the attack under way might run out of $$ if they are paying. I tried the anti ddos from Wodka and no good. I'm running xps3 if that matters. Anyway, I'm geting dyn dns so noone can see the actual ip of the server while logging in,. Maybe that will help.

Posted on: 2015/11/30 23:01
Top
Re: Killing server due to no flhook response
Starport Admin
Joined:
2009/2/21 21:42
Group:
Webmasters
Registered Users
Posts: 3447
Offline
The thread specifically and repeatedly mentions that the DDOS DLL only works under Windows 7/Windows Server 2008.

You really aren't helping your chances by sticking with such a vulnerable piece of shit as XP.

Also, FL resolves the IP of the server and displays that, so a DNS is pointless.

Posted on: 2015/12/1 15:00
"Cynicism is not realistic and tough. It's unrealistic and kind of cowardly because it means you don't have to try."
-Peggy Noonan
Top