Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
57 user(s) are online (32 user(s) are browsing Forum)

Members: 0
Guests: 57

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +0€

Current balance: 55€
(last updated 04/2021)

Please make a donation if you want to help keeping The-Starport online:

Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 40 users playing Freelancer on 44 servers.
July. 6, 2022
The Starport Forum Index > All Posts (Wixelt)

Bottom Bottom   Previous Topic   Next Topic

« 1 2 3 4 (5)


Pathing (Waypoints) in Modded System (Solved-ish)
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
I've been gradually building up a custom star system in order to familiarize myself with various parts of modding Freelancer, and i'm currently looking at trying to get waypoints to work in relation to it.

At first, since the save i'm using sits somewhere in the middle of the single player campaign right now, the mission start waypoint for the next mission pointed to the 0, 0, 0 of the system, would have the glitch of the unselected waypoint remaining on-screen as well as the selected graphic and would only disappear if I set a player waypoint somewhere else in the system.

Eventually, I got this half-fixed. After locating the system_shortest_path.ini file, I added path information relevant to my system to it and was able to get the automated story waypoints to seemingly point where they're supposed to from inside my system, but I still have another issue i've had since the start: I can't set player waypoint routes outside of the system, getting a 'No Best Path' message anytime I try.

I attempted to fill out path information tied to my system into the shortest_illegal_path.ini to fix this (not adding anything to the legal equivalent because my system has no jump gates), but I still get the 'No Best Path' message, and i'm now out of ideas.

Is there an index or list I need to add my system into for this to work that i'm missing?

Posted on: 2020/6/3 15:55
Top
Topic | Forum


Re: Custom Infocard DLLs not appearing in-game
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

Cpt_Rei_Fukai wrote:
So your FLMM mod replaces dlls from Freelancer with your own ones? If so you don't need to add them to the resources

I have all my names and infocards in two DLL files separate to the vanilla ones. It's mainly so I can more easily keep track of what i've inserted. The FLMM mod contains a version of the freelancer.ini which has them listed in the resources.

Quote:

Cpt_Rei_Fukai wrote:
Fled-IDS is great for this.

I'll take a look at it shortly. Thanks for the link.

Quote:

Cpt_Rei_Fukai wrote:
Technically the infocards are xml, though some of the syntax is similar to HTML. I don't think FL supports HTML.

I get the impression ResourceHacker just registers it as HTML because of the similar syntax, then, so maybe that's where the issue is. That said, if Fled-IDS ends up solving all this, that won't be a problem anymore.

Quote:

Cpt_Rei_Fukai wrote:
FLspew is Freelancers logfile, it is located at %User%\Appdata\Local\Freelancer\

FLScan II is a great tool to find errors in your mod...

Thank you for linking both of these. They've already helped me squash a couple of bugs related to something else I was having issues with. One more thing I can check off.

Posted on: 2020/6/1 21:32
Top
Topic | Forum


Re: Custom Infocard DLLs not appearing in-game
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

Cpt_Rei_Fukai wrote:
Well there are many possible mistakes to be made, so I will just post a list for you to check:

-Have you added your dll in the Resources Section of the freelancer.ini?

Yes. I have my mod hooked up to FLMM for testing, and the mod files contain a version of freelancer.ini that has both of my DLLs (one for names and one for infocards), that is otherwise identical to the vanilla one and supercedes it whenever the mod's active.

Quote:

Cpt_Rei_Fukai wrote:
-is your dll in the Exe folder?

Yes.

Quote:

Cpt_Rei_Fukai wrote:
-are the ids_info numbers you are referencing contained in your dll?

It's hard to tell in the program I actually edit with, but when I check it using the Importer/Exporter, the infocards are associated with specific ID numbers (and it puts a little '(i)' next to them, so I know it's recognizing the difference between names and infocards), so I assume that means they're in the DLL.

Quote:

Cpt_Rei_Fukai wrote:
-is the dll correctly formatted? I don't know the tool you are using, I've always used Fled-IDS and adoxas frc. If you think this is the issue, then you can post it so we can check it.

The name DLL's information shows up in game perfectly fine, so if there is a formatting issue, it could be tied to the infocard DLL using HTML?

As for the program, I'm currently using Resource Hacker. I originally looked at programs like FLed-IDS and the FRC, among others like FLDev, but I got frustrated with not being able to work out how to make them save off my infocards (FLDev), not being able to find a download link to get the program to begin with (FLed-IDS), or just being too impatient at the time after previous issues to work through a command prompt interface (FRC).

My plan is to go back and look at these with a clearer head once i've got a better grasp on the overall Freelancer structure and am less likely to get annoyed over it, though, as i've heard only good things about IDS and FRC's functionality once you understand them.

For now, though, Resource Hacker has done names perfectly fine, and if I can make it do other Infocards properly too, that would be ideal.

Quote:

Cpt_Rei_Fukai wrote:
-maybe flspew.txt, the server console or flscanII will tell you something

I'm not sure what flspew or flscanII are, though the names seem familiar. As for using the server console, that may be something I look into provided I can set up local hosting.

Thank you for the feedback, by the way. I appreciate it.

Posted on: 2020/5/31 16:19
Top
Topic | Forum


Custom Infocard DLLs not appearing in-game (Solved)
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
New to both the forum and modding Freelancer, but i've been playing the game on and off for a long time.

I know there's probably a simple answer, and i've seen similar topics on a few threads that have got me this far, but I thought it best to just ask rather than banging my head against a wall.

I've been getting into modding by building an original system with custom infocards and names. The system works fine and the name DLLs translate into the game perfectly, but the infocards for the system and its star, and probably other objects if I were to make them, don't turn up in-game.

I have FL Infocard Importer/Exporter installed and have been using it to check entries for errors, and both output "WARNING: '>' not found at end of ids ______", which is pretty self-explanatory.

That said, there doesn't seem to be a '>' missing from either and at a glance my infocards' HTML looks the same as the vanilla ones'. I briefly thought it was a glitch that an extra '>' or '</ >' on the end might fix, but I was wrong.

Turns out having course experience in programming means nothing when you're faced with a layout you're completely unfamiliar with.

Is there a simple and obvious fix to this that i'm missing? If needed, I can provide wider details on how i'm going about modding, though it's been slightly haphazard so far as I've been flitting around a bit as I work out what processes and programs work best for me.

Posted on: 2020/5/30 22:37
Top
Topic | Forum



Top Top
« 1 2 3 4 (5)



[Advanced Search]