Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
67 user(s) are online (12 user(s) are browsing Forum)

Members: 0
Guests: 67

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +0€

Current balance: 55€
(last updated 04/2021)

Please make a donation if you want to help keeping The-Starport online:

Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 62 users playing Freelancer on 45 servers.
May. 22, 2022
The Starport Forum Index > All Posts (Wixelt)

Bottom Bottom   Previous Topic   Next Topic

« 1 2 3 (4) 5 »


Dockable Osiris Not Working (Solved)
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
I searched for some help on this and got half an answer in another thread which fixed some issues, but I still need some help with this.

I'm trying to set up a dockable post-game Osiris. Originally it wasn't even appearing in the version of Omicron Minor I set up, but I managed to find a forum thread here that explained how to fix that (I created a separate loadout entry for the post-game Osiris that copied the regular entry minus the cloaking device).

Now, though, when I try to dock, it does the docking sequence (slow with a dramatic fade, because it's a "unique to the campaign" ship), but once it fades to black... nothing. It doesn't cut to the ship interior and stays on that black screen.

I can tell it's stuck at the end of the dock sequence because when I pause the game I can see past the black and the exterior the Osiris is still visible, and my first thought is that it's looking for a mission specific scene trigger, but i'm stumped beyond that.

I can provide any entries or alterations i've made if need be.

Posted on: 2020/6/8 0:51
Top
Topic | Forum


Re: Zone Questions
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

Thaddeus wrote:
not sure about the first - would have to see what you have done. Mining zones are controlled by the DATA\SOLAR\ASTEROIDS\system_your_asteroids.ini

Property flags do not affect the visibility of the zone only the visit = line in the system.ini does that - and you have to go there to add it to you nav-map.

Quote:

Cpt_Rei_Fukai wrote:
This site has a seach function, so try it out

Anyway to your questions:
1. A zone is displayed as minable in the navmap depending on it's visit parameter
Property flags change the display on the navmap, e.g asteroids or nebula etc.

I considered that it might be a visit thing, but the only values i've known for that up til now have been 0, 1 and 128, none of which are related to mineable zoning. Having looked at the lists in the links, the property flags list shown there is actually the one i've been consulting for other things, but I couldn't work out how to put the '0x-' numbers into context (and still am a little, but that's what trial and error is for), whilst the other visit numbers are news to me and are a big help. I'm assuming that a mineable zone (4), is automatically invisible until visited, or would be a 5 if it wasn't?

And I probably should search more. It's a bad habit of mine not to when i'm the middle of doing something and can't immediately find what i'm looking for.

Quote:

Thaddeus wrote:
your 2nd Q - radiation level is set by the damage = x line of the [zone] you have surrounding you object (or just an ambient radition zone) in the system.ini file

Quote:

Cpt_Rei_Fukai wrote:
2. As Thaddeus said, simply add a "damage"(Range = 0-inf) parameter to your zone for "radiation damage".
If you want to reduce the sensor efficiency simply add the parameter "interference"(Range = 0.0-1.0).

I know I have damage values for planetary atmospheres and sun coronas, but I wasn't sure if that also worked for general radiation. These numbers, both for radiation and sensor efficiency (which i'm going to use more immediately) are good to know, though. Hopefully this isn't something i'll have to ask again.

Thank you.

Posted on: 2020/6/7 12:49
Top
Topic | Forum


Re: Pathing (Waypoints) in Modded System
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

Cpt_Rei_Fukai wrote:
I investigated a bit and it seems FL always tells you "No best path" if a system cannot be reached with jumpgates. For example plotting a course to Omicron Alpha tells me "No best path" as well.

Adoxas FLHack has an option for that.

Really? huh. I've been playing Freelancer since I was a kid, you'd think i'd have notice this by now.

Well, given the modding i'm doing, i'll leave this as is rather than using FLHack to try and fix it. Glad to know it's not just my system being buggy.

Posted on: 2020/6/7 12:25
Top
Topic | Forum


Zone Questions (Solved)
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
This is actually two questions in one, but I didn't want to post two very short questions as separate threads when they're both related to similar things:

1) The areas in the star system i'm building that are mineable (an ice cloud and ice field, respectively), don't show up as mineable zones on the navmap, even though I know they are. Is there a way to fix this, as i'm not seeing an option for it in the information I have on property flags, which is where i'd expect it to be.

2) I'm trying to set a radiation or sensor reduction zone around a wreck, and have been looking for the object/zone responsible for that in other system INIs, but can't seem to find it or whatever value it requires. Is the data or setting for something like that stored elsewhere (like in the wreck itself, for example)?

I'd appreciate any feedback I can get on these things.

Posted on: 2020/6/6 18:40
Top
Topic | Forum


Re: Patrol Routes Causing Crash?
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

robocop wrote:
Might also be the encounters themselves. If they're not set up properly that can cause what you describe. Create the patrol path but leave out the encounters, then add in each encounter until the crashes resume. If the crashes resume after adding the first encounter it's either the patrol path itself (see advice in above posts) or the encounter. If the crashes don't resume until a later encounter is added it may be that last added encounter.

I have also been getting crashes related to encounters, as it happens, but it's generally been because i've forgotten to insert a reference to the encounter archetype required at the start of the system ini.

Right now, though, everything seems to be working fine.

Posted on: 2020/6/6 15:26
Top
Topic | Forum


Re: Patrol Routes Causing Crash?
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Still having a crash problem, though now that i'm examining it again I think it might also be being caused by my labeling patrol paths incorrectly (hadn't realized it wasn't arbitrary and they're actually grouped for a reason, which was stupid of me).

Thank you, though. This was definitely one half of the problem.

Posted on: 2020/6/6 11:41
Top
Topic | Forum


Re: Patrol Routes Causing Crash?
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

Skotty. wrote:
Is this running on a server or singleplayer?
Patrol routes do need the following conditions met:
- Each end point must be a dockable location NPCs can spawn or disappear to.
- If the endpoint is a base, the mbase factions must contain the patrolling NPC faction.
Make sure if jumpholes or gates are the endpoints that the NPC faction is allowed to dock at them.

This might be the problem, then. The end of the route currently ends on open space.

If I implemented the rest of my patrol route objects, which as far as i'm aware has all ends either intersecting with a base, hole or another route object, would that likely stop the crash?

Posted on: 2020/6/6 1:29
Top
Topic | Forum


Patrol Routes Causing Crash? (Solved)
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
I've been gradually implementing patrol routes into the star system i'm building to get used to modding, but i've run into an error, specifically a recurring crash, that I can't see a specific cause for on either FLSpew or FLScanII.

This is my system:
Open in new window
































Whenever I get close to the planet in the middle left of the system, the game flickers to a black screen then closes, which i've seen before when the game's run into certain errors (usually when it couldn't find something).

I'm pretty sure it's being caused by the vertical route passing behind the planet, as the diagonal route above it (where the player icon currently is on the screenshot) had patrols along it fine before the vertical was added in, as were the other patrol routes and everything else in the system as I far as I could tell.

I can't find anything in the zone block for the vertical that makes it that different from the others (and i'll share all of them if people ask to take a look), or any patrol encounter references that would seem to be alluding to archetypes that aren't there, so i'm kind of stumped.

Posted on: 2020/6/5 14:04
Top
Topic | Forum


Re: Pathing (Waypoints) in Modded System
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

I have and have used FLScan, and the only system specific thing that comes out is to do with the LightSource, and there's the same message for a lot of vanilla systems too. I don't see any errors related to pathing.

Posted on: 2020/6/5 0:22
Top
Topic | Forum


Re: Starting Single Player Without Campaign
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
This has a massive chunk of what I was looking for. Thank you.

Is Chips still around? I'd like to ask if I can have their permission to use this as part of the groundwork for what i'm thinking of working on. If not, I can still try and learn what they did to implement it myself.

Posted on: 2020/6/5 0:17
Top
Topic | Forum


Re: Starting Single Player Without Campaign
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Thank you. I'll take a look at this now.

Posted on: 2020/6/4 23:22
Top
Topic | Forum


Starting Single Player Without Campaign
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
This is actually several modding questions rolled into one, but they all tie back to the same thing.

As part of an idea I have, i'm looking to set up a custom start for a mod project. By this I mean all opening cinematics are skipped, no story missions are started and single-player possibly begins on a base aside from Manhattan with the player already having a ship (I'd also like to see if I can change the start ship and begin building a custom campaign, but the latter at least is beyond my skill right now, so will be for another day).

I've heard a mod called OpenSP (?) might be able to do at least some of this, but I don't know if you need permission to begin building on top of someone else's mod (though i'd assume you would), so would prefer to see if I can arrange this setup from the ground up instead.

Are there any simple changes that can achieve at least some of this?

Posted on: 2020/6/4 14:04
Top
Topic | Forum


Re: Pathing (Waypoints) in Modded System
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

Thaddeus wrote:
Quote:

starworld wrote:
1) delete : shortest_illegal_path.ini, shortest_legal_path.ini, systems_shortest_path.ini
2) run FLServer.exe


I have never got that to work. Every time I try it flserver just crashes out, not having written anything.

Here's something that half works, then.

I tried removing the ini files and running FLServer.exe, as suggested, but it just stuck loading forever and didn't do anything.

What did do something, though, was running Freelancer itself instead of the server program. This resulted in the creation of pathing files that seem to more organically contain system data that includes my modded system, which i've copied back into my original mod compile so I don't loose them.

The only issue is that even though this is preferable to my inputting everything myself (and i'm definitely going to remember that Freelancer does this for future reference), it hasn't solved me not being able to set player waypoints from my modded system to other systems, as i'm still just getting the 'No best path' text whenever I try.

Posted on: 2020/6/3 23:19
Top
Topic | Forum


Re: Pathing (Waypoints) in Modded System
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

Cpt_Rei_Fukai wrote:
Afaik those files hard code pathing information using different routes.

The idea is that every possible source system has got path info on how to get to every possible destination system. If a system is not in this list, you get the error you described. The different files use different travel methods; eg. only jumpholes; only jumpgates; any

Seems like you only added routes TO your system, but no entry for travels FROM your system.

Maybe deleting those files makes FL calculate the route on the fly?

Could be, though I did also put in entries that seemed to be routes from the system (actually did that first before realizing that on its own hadn't done anything).

I'll try deleting the files, then. My thought is that it will force the game to create new files containing references to the new system within them, but i'll just have to wait and see.

Posted on: 2020/6/3 20:17
Top
Topic | Forum


Re: Pathing (Waypoints) in Modded System
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

starworld wrote:
1) delete : shortest_illegal_path.ini, shortest_legal_path.ini, systems_shortest_path.ini
2) run FLServer.exe

Before I go and start deleting things (or at least renaming things to get them out of the way), can I ask what that's going to do? I have an idea of what might happen, but I want to be sure.

Regardless, thank you for the quick response.

Posted on: 2020/6/3 16:47
Top
Topic | Forum



Top Top
« 1 2 3 (4) 5 »



[Advanced Search]