Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
62 user(s) are online (34 user(s) are browsing Forum)

Members: 0
Guests: 62

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +0€

Current balance: 55€
(last updated 04/2021)

Please make a donation if you want to help keeping The-Starport online:

Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 42 users playing Freelancer on 44 servers.
July. 6, 2022
The Starport Forum Index > All Posts (Wixelt)

Bottom Bottom   Previous Topic   Next Topic

(1) 2 3 4 5 »


Re: Modded Game Crashing Pre-Menu
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quick update: I've managed to fix the crashes. Because I was running low on options, I started just pulling out files and replacing them with the vanilla's game's to see if anything changed. On my first copy-over, which was common.dll, the mod stopped crashing.

Thank you all for the assistance, as i'd probably have given up again and not reached this point without it.

Posted on: 2021/9/4 15:50
Top
Topic | Forum


Re: Modded Game Crashing Pre-Menu
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

adoxa wrote:
That seemed to work fine. Is that the one that crashes on yours?

It's from the mod that causes the crash that says it can't load the server.dll. If you're running that fine, then, I can only really assume the issue is another file in the mod not loading the DLL, rather than the DLL itself.

Edit: A minor update. Went into the Event Viewer (which I was avoiding doing as I can never find where it shows crash offset codes in Windows 10, and still can't), and after trying and failing to run FLServer, it spat out this error:

Code:
Application pop-up: FLServer.exe - Entry Point Not Found : The procedure entry point [email protected]@[email protected] could not be located in the dynamic link library C:\Program Files (x86)\Microsoft Games\Freelancer\EXE\Server.dll.

Posted on: 2021/9/3 15:01
Top
Topic | Forum


Re: Modded Game Crashing Pre-Menu
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

adoxa wrote:
Could you post the mod's server.dll?

I haven't dared touch it because my knowledge of hex outside of specific instructions given for one thing or another is essentially non-existent. That said, i'm trying to upload it, but the forum isn't allowing me to. Something about the MIME type (application/x-msdownload) not being allowed.

Edit: Nevermind. It seems to work when I put it in a compressed folder. I hope that comes out alright in the download.

Attach file:


zip server.zip Size: 298.43 KB; Hits: 41

Posted on: 2021/9/3 13:50
Top
Topic | Forum


Re: Modded Game Crashing Pre-Menu
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

Raikkonen wrote:
If you have the .dll I wonder if its an access issue.

Are you running the game as Administrator?

Is the .dll blocked? See example screenshot.

The Server.dll in my mod doesn't seem to be blocked, and I set the freelancer.exe to run as Admin, but it didn't change anything. Good thought, though.

Posted on: 2021/9/3 13:20
Top
Topic | Forum


Re: Modded Game Crashing Pre-Menu
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

adoxa wrote:
Quote:
Code:
E:\FL\Scratch\Source\RPCLocal\RPCServer.cpp(62) : *** ERROR: Connect - failed to LoadLibrary(server.dll)

Well there's your problem - you have no EXE\server.dll. Heaven knows what else is missing, then, do a fresh install.

That's confusing then, because if it is the server.dll that's the problem, the mod does actually have one, and Freelancer runs just fine when the mod's uninstalled, meaning a reinstall might not solve it. I'd assume then, that the problem is the server.dll in the mod being in error, but I feel like i've attempted to replace it with the wprking, vanilla one before, and since I don't think i've edited the server.dll during any other work on the mod (the closest I think would be my mixed success attempt to remove the level cap, which didn't touch the server.dll, as far as I remember) I assume I copied it over just in case.

Actually, if the server.dll is the issue, I might see what happens if I just remove it from the mod. Maybe having it there to overwrite the default one when I don't need it is the problem. Will see if this works and then edit here if it does.

Edit: Didn't work. I'm considering that reinstall, now, but still don't think it will solve the problem.

Posted on: 2021/9/3 10:54
Top
Topic | Forum


Re: Modded Game Crashing Pre-Menu
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

SWAT_OP-R8R wrote:
then more info is required

I'm unsure what other info I have to provide at the moment. Originally there were several other significant errors FLScanII was picking up, but I managed to track down their causes and fix them, so what's been talked about on this thread is more or less all i've got to work with right now.

Edit: Also, I have discovered the cause of the error (thought it was the leftover files from another mod in my file backup that I missed previously, but it really was the MultiUniverse entry in universe.ini not naturally needing a file directory - adding one but leaving it blank removes the error), so now i'm just down to whatever's in FLSpew for whatever's causing my crash.

Posted on: 2021/9/2 18:34
Top
Topic | Forum


Re: Modded Game Crashing Pre-Menu
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

You should double check that. When being launched, FL automatically creates a savegame if there is none. If you did changes to the modded content since that happened it still might be possible that such an incompatibility is the cause.

I tried renaming the entire Accts folder at one point to force the generation of a new one, and I still got a crash. I don't think the saves are the problem, or at least not the root issue.

Posted on: 2021/9/2 16:37
Top
Topic | Forum


Re: Modded Game Crashing Pre-Menu
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

Yeah, that would do it.

As for your crash, could it be an intro? Nothing in the spew?

If that's what's causing the fatal error, that might not be the cause of the crash, given I feel like i'd had MultiUniverse integrated for a while before the crashes started.

As for the spew, I did find this. Not sure why this line didn't stand out to me before when I looked since this seems like something that'd cause a crash:

Code:
E:\FL\Scratch\Source\RPCLocal\RPCServer.cpp(62) : *** ERROR: Connect - failed to LoadLibrary(server.dll)
E:\FL\Scratch\Source\DALib\DALib.cpp(376) : WARNING:General:******* DA SYSTEM: trailing references *******
E:\FL\Scratch\Source\DALib\DALib.cpp(376) : WARNING:General:******* DA SYSTEM: trailing references *******

Posted on: 2021/9/2 16:30
Top
Topic | Forum


Re: Modded Game Crashing Pre-Menu
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

adoxa wrote:
DATA\UNIVERSE\universe.ini has a [system] without a file = ....

I have MultiUniverse as part of my mod files. Would its region entries in the Universe.ini not having a file directory trigger the error?

Quote:

SWAT_OP-R8R wrote:
Putting aside that this clearly is an error I have my doubts that it can explain the crash at this early point.
FL seems to load the system files at a later point.

It's pretty hard to tell what causes such a crash without further info but the vast amount of crashes at this specific point are related to savegames being no longer compatible with the modded files. It would be worth a try to rename the savegame folder and try to load the game then.

I read the issue with save files somewhere before, I think, and tried that. The mod presently doesn't have any save files attached to it and still crashes out, though thanks to how the Mod Manager handles seperating modded files, they're still there in a split off folder.

Posted on: 2021/9/2 14:30
Top
Topic | Forum


Modded Game Crashing Pre-Menu (Solved)
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
For a while, i've been having a problem with a mod i've been working on, where it crashes between the title card and the main menu. When this has happened before, it was the result of something incorrect or missing, but i've struggled to track down the cause.

Up til now, i've used FLScanII to root it out, and have fixed several other minor issues en-route, but though this has helped me narrow the issue down to probably being in the MISSIONS folder - maybe in factionprop.ini - i'm not versed enough in the errors FLScanII's giving me to know where to look past that.

The fact that the scan aborts looking at the MISSIONS folder at this point doesn't help, so all i've really got to go on is this:

Code:
[info] Checking faction_prop.ini
[fatal] Scan aborted: setting file not found in section system


Help would be appreciated, as this issue has effectively killed my enthusiasm for modding.

-Wixelt

Posted on: 2021/9/1 23:27
Top
Topic | Forum


Re: Increasing SP Level Cap Beyond 38/40?
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
I think, after accidentally bricking my game files by accident several times trying to work it out, i've managed to narrow it down to one line from FLSpew for what's probably causing this crash.

E:\FL\Scratch\Source\RPCLocal\RPCServer.cpp(62) : *** ERROR: Connect - failed to LoadLibrary(server.dll)

It's not able to load the server.dll for some reason (my mod doesn't have a unique server.dll to replace the basic one). I've double checked this by trying to load a server rather than start the game, and I run into an error there flat out.

Posted on: 2020/7/27 22:31
Top
Topic | Forum


Re: Files Not Loading with FLMM Activation
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Fixed them not loading in, I think. Beyond that, was still having an issue with them not playing, but that was tied to my not realizing Music.ini existed and thinking the system ini just looked for the name directly from the file, so hopefully there'll be no more issues there.

Posted on: 2020/7/25 15:54
Top
Topic | Forum


Files Not Loading with FLMM Activation (Solved-ish)
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
I'm having trouble loading some custom audio files using Mod Manager (v1.5 beta 1, as I installed it before I knew there was a newer version and haven't gotten around to upgrading).

I put the files, a set of custom space tracks, in my mod's folder in the correct location, activate the mod, and all seems to be running fine... except space in the system i've set up to test the music is silent and the files aren't present in the correct folders when I check the main directories with the mod active.

Is there a reason for this? My first assumption is that FLMM isn't picking up the .wav files because the formatting's wrong, but that feels incorrect.

Posted on: 2020/7/21 21:50
Top
Topic | Forum


Re: Increasing SP Level Cap Beyond 38/40?
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
Quote:

adoxa wrote:
No nickname and nickname of 0 are probably the same thing. The simples are or_elite_dmg_star_wing_cap and or_elite_dmg_port_wing_cap. Copy of Anubis?

I do have one, yes, though I plan to replace the model if I ever get better at modelling. That said, the dupe's been there for a while now and hadn't been causing issues.

Posted on: 2020/7/14 15:01
Top
Topic | Forum


Re: Increasing SP Level Cap Beyond 38/40?
Not too shy to talk
Joined:
2020/5/29 17:34
Group:
Registered Users
Posts: 64
Offline
No ArchDB in FLSpew, so i'm beginning to suspect that the error log I posted might actually be from what I was working on before the crash issue, as that involved solar objects. There's no major errors related to Freelancer that are newer than it, though, so I can only assume the load crash isn't creating error logs.

The FLSpew, did, however, contain the following in its final few lines:

Code:
E:\FL\Scratch\Source\Common\Archetype.cpp(132) : *** ERROR: Loaded 'Ship' has no nickname .. not adding to database.
E:\FL\Scratch\Source\Common\Archetype.cpp(1643) : *** WARNING: [Ship] nickname = 0x0 value is not unique. Aborted second version.
E:\FL\Scratch\Source\Common\Archetype.cpp(868) : *** WARNING: [Simple] nickname = 0x8bbbb587 value is not unique. Aborted second version.
E:\FL\Scratch\Source\Common\Archetype.cpp(868) : *** WARNING: [Simple] nickname = 0xa06c930c value is not unique. Aborted second version.
E:\FL\Scratch\Source\Client\main.cpp(556) : *** ERROR: Couldn't load content.dll! Error code 127
E:\FL\Scratch\Source\Client\nn\NN_Chat.cpp(1362) : NOTICE:General:Channel add successful.
E:\FL\Scratch\Source\Client\nn\NN_Chat.cpp(1362) : NOTICE:General:Channel add successful.
E:\FL\Scratch\Source\Client\nn\NN_Chat.cpp(1362) : NOTICE:General:Channel add successful.
E:\FL\Scratch\Source\RPCLocal\RPCServer.cpp(62) : *** ERROR: Connect - failed to LoadLibrary(server.dll)
E:\FL\Scratch\Source\DALib\DALib.cpp(376) : WARNING:General:******* DA SYSTEM: trailing references *******
E:\FL\Scratch\Source\DALib\DALib.cpp(376) : WARNING:General:******* DA SYSTEM: trailing references *******

Posted on: 2020/7/14 13:50
Top
Topic | Forum



Top Top
(1) 2 3 4 5 »



[Advanced Search]