Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
57 user(s) are online (28 user(s) are browsing Forum)

Members: 0
Guests: 57

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +0€

Current balance: 55€
(last updated 04/2021)

Please make a donation if you want to help keeping The-Starport online:

Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 56 users playing Freelancer on 37 servers.
May. 7, 2021

Browsing this Thread:   1 Anonymous Users



 Bottom   Previous Topic   Next Topic  Register To Post



Error / Bug in FLMM-generated ids_info (XML)
Home away from home
Joined:
2010/2/22 0:47
Group:
Registered Users
$$$ Supporters $$$
Senior Members
Posts: 928
Offline
One of the FLMM-generated ids_info's in my mod is bugged, but I cannot find what I did wrong.

Problem is: the text is displaced twice:
- first correctly, as intended
- right after with al the <XML>, <RDL> tags etc. visible in-game.

I can't copy-and-paste as the comp I use to connect to the internet is not the one where my mod is on (I'm at my workplace now )

I wonder if I did something wrong, or if this a known bug / issue. Anyone any ideas what might trigger this phenomenon?

I already replaced the " in the script with ' , to differentiate them from the ones that include the entire XML script. This does not make a difference.

Thanks in advance for any input.

Posted on: 2010/4/10 8:13
Top
Re: Error / Bug in FLMM-generated ids_info (XML)
Home away from home
Joined:
2010/2/22 0:47
Group:
Registered Users
$$$ Supporters $$$
Senior Members
Posts: 928
Offline
Hmmm.... FLMM says it parsed an error: found </SCRIPT> without preceding <SCRIPT>.

It is not in the file it says it is, but I might be on the right track. I'll report back when I located it.


EDIT: found it. Mentioned error was caused by a missing </data> tag.

Whether this is also the cause for the ids_info issue I opend this thread about, remains to be seen. I'll check it out in a minute... BRB

Posted on: 2010/4/10 8:29
Top
Re: Error / Bug in FLMM-generated ids_info (XML)
Home away from home
Joined:
2010/2/22 0:47
Group:
Registered Users
$$$ Supporters $$$
Senior Members
Posts: 928
Offline
No, the correction of the </data> tag did not influence the issue described in post #1, so my question/request remains:

Anyone any ideas what might cause the issue described?

Thanks in advance!

Posted on: 2010/4/10 8:36
Top
Re: Error / Bug in FLMM-generated ids_info (XML)
Home away from home
Joined:
2010/2/22 0:47
Group:
Registered Users
$$$ Supporters $$$
Senior Members
Posts: 928
Offline
SHAME ON ME

After looking at it again, for the upteenth time, I noticed a part that went

<TEXT> <TEXT>

but should have been

<TEXT> </TEXT><PARA/><TEXT>

After the correction, the text was displayed correctly.

That means I've waisted 4 posts of serverspace, and some valuable minutes of anyone who read it. I'm okay with a possible moderator's decision to remove this entire thread. But it could also remain as a monument to remember that errors can be easily overlooked

Posted on: 2010/4/10 8:45
Top
Re: Error / Bug in FLMM-generated ids_info (XML)
Home away from home
Joined:
2008/6/2 10:17
Group:
Registered Users
$$$ Supporters $$$
Senior Members
Posts: 1847
Offline
Yep, don't feel bad, it's a good pointer for someone else as a reminder. I need glasses at the best of times to find problems like that one.

But as you can see we couldn't really help without your data in sight.

Posted on: 2010/4/10 23:06
"C" for "Caterpillar"... "Cool"... "Cheesey"!
Top