Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
51 user(s) are online (31 user(s) are browsing Forum)

Members: 0
Guests: 51

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +0€

Current balance: -100€
(last updated 09/2018)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 87 users playing Freelancer on 33 servers.
September. 24, 2018

Browsing this Thread:   1 Anonymous Users



 Bottom   Previous Topic   Next Topic  Register To Post



FLServer port not binding under Windows 7

Joined:
2009/10/12 15:37
Group:
Registered Users
FLServer Admins
Posts: 46
Offline
I'm looking for some help with getting flserver.exe running under Win7. Does anyone have a flserver actually up and running under Win7? I've tried several things to no avail and am looking for a bit of help if anyone has run into this behavior.

Flserver will launch, startup, and appear fully functional. It will however not bind it's listen port to the IPv4 address of the machine.

Here is what I've tested:

I have 3 Win7 Enterprise x64, 2 Win7 Enterprise x86, and 1 Win7 Home x64 PCs.

I have turned off IPv6 on all machines. Previously flserver would show a binding with IPV6 turned on using "netstat -ano", but a client machine could not connect. On the client the IPv6 IP would be displayed as the server's IP address.

I have tried the suggested registry change to ensure IPv6 is fully disabled on the machines (both documented settings for DisabledComponents to "000000ff" and "ffffffff").

I have turned off the firewall service on the machines.

I have removed all AV software (or in one machine's case, performed a full install from DVD of W7x64 Enterprise).

I have used "netstat -ano" to display the open ports. flserver is shown but with 2 completely random UDP ports. flserver on a working machine (a 2008 R2 server) shows the selected listen port and one other random port open.

I have run a base flserver.exe with no add ins, or server with FLHook included.

I have tried numerous other port settings using the /p command line option for flserver (/p2302, /p2900, /p12000, etc). Any port selected will not be mapped when viewed with netstat.

I have run the client on the same machine as the server. It cannot see itself (just to ensure netstat wasn't misleading me).

I would appreciate any insight fellow freelancers could offer.

Edit: I've also tried running flserver as an admin (I'm an admin anyway on the machine), using various compatibility modes, etc.

Posted on: 2011/3/1 1:02

Edited by Xevious on 2011/3/1 1:23:37
Open in new window
Top
Re: FLServer port not binding under Windows 7
Just can't stay away
Joined:
2008/2/16 15:03
From UK
Group:
Registered Users
Senior Members
Posts: 252
Offline
I have it running after disabling ipv6 you need to right click my computer go to properties then device manager.

Click "view" then "show hidden devices", then under network adapters disable "Teredo Tunneling Pseudo-Interface"

Please note you will have to repeat this each time your pc is turned off then back again.

Posted on: 2011/3/1 13:47
Top
Re: FLServer port not binding under Windows 7
Just can't stay away
Joined:
2009/11/30 19:02
Group:
Registered Users
Senior Members
Posts: 391
Offline
The TSP Wiki links to this article, I think it may help.

http://www.windowsvalley.com/disable- ... completely-on-windows-os/

EDIT: Ah, I see you've already done the registry fix. Well then, use the above mentioned method, otherwise I'm stumped. :\

Posted on: 2011/3/1 15:55
Open in new window
Top
Re: FLServer port not binding under Windows 7
Starport Staff
Joined:
2008/10/7 19:56
From England
Group:
Registered Users
Starport Staff
FLServer Admins
$$$ Supporters $$$
Senior Members
Posts: 632
Offline
Can you screenshot it please? I think I know the problem you're talking about.

Posted on: 2011/3/1 16:15
Top
Re: FLServer port not binding under Windows 7

Joined:
2009/10/12 15:37
Group:
Registered Users
FLServer Admins
Posts: 46
Offline
Quote:

Dragnite_MU wrote:
I have it running after disabling ipv6 you need to right click my computer go to properties then device manager.

Click "view" then "show hidden devices", then under network adapters disable "Teredo Tunneling Pseudo-Interface"

Please note you will have to repeat this each time your pc is turned off then back again.


I actually killed that already. Here's what showing as hidden (see attached jpg):


Attach file:



jpg  devices.jpg (112.47 KB)
1322_4d6ee017cc5d8.jpg 611X609 px

Posted on: 2011/3/3 0:26
Open in new window
Top
Re: FLServer port not binding under Windows 7

Joined:
2009/10/12 15:37
Group:
Registered Users
FLServer Admins
Posts: 46
Offline
Quote:

=Alex= wrote:
Can you screenshot it please? I think I know the problem you're talking about.


Screenshot of netstat? This is netstat's results with flserver up and running (bound to port 2302 -- or at least that's what I told it to bind to). Flserver is PID 1680 in this list.

Code:


Active Connections

  Proto  Local Address          Foreign Address        State           PID
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       864
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
  TCP    0.0.0.0:5357           0.0.0.0:0              LISTENING       4
  TCP    0.0.0.0:49152          0.0.0.0:0              LISTENING       556
  TCP    0.0.0.0:49153          0.0.0.0:0              LISTENING       1000
  TCP    0.0.0.0:49154          0.0.0.0:0              LISTENING       424
  TCP    0.0.0.0:49155          0.0.0.0:0              LISTENING       608
  TCP    0.0.0.0:49192          0.0.0.0:0              LISTENING       664
  TCP    192.168.10.151:139     0.0.0.0:0              LISTENING       4
  TCP    192.168.10.151:57899   192.168.10.10:8014     ESTABLISHED     1312
  TCP    [::]:135               [::]:0                 LISTENING       864
  TCP    [::]:445               [::]:0                 LISTENING       4
  TCP    [::]:5357              [::]:0                 LISTENING       4
  TCP    [::]:49152             [::]:0                 LISTENING       556
  TCP    [::]:49153             [::]:0                 LISTENING       1000
  TCP    [::]:49154             [::]:0                 LISTENING       424
  TCP    [::]:49155             [::]:0                 LISTENING       608
  TCP    [::]:49192             [::]:0                 LISTENING       664
  UDP    0.0.0.0:123            *:*                                    1092
  UDP    0.0.0.0:500            *:*                                    424
  UDP    0.0.0.0:3702           *:*                                    1856
  UDP    0.0.0.0:3702           *:*                                    1856
  UDP    0.0.0.0:4500           *:*                                    424
  UDP    0.0.0.0:5355           *:*                                    1372
  UDP    0.0.0.0:50828          *:*                                    1856
  UDP    0.0.0.0:54041          *:*                                    1680
  UDP    127.0.0.1:1900         *:*                                    1856
  UDP    127.0.0.1:51104        *:*                                    664
  UDP    127.0.0.1:51105        *:*                                    1372
  UDP    127.0.0.1:52770        *:*                                    1272
  UDP    127.0.0.1:56461        *:*                                    1312
  UDP    127.0.0.1:57792        *:*                                    5208
  UDP    127.0.0.1:61422        *:*                                    424
  UDP    127.0.0.1:61565        *:*                                    1856
  UDP    192.168.10.151:137     *:*                                    4
  UDP    192.168.10.151:138     *:*                                    4
  UDP    192.168.10.151:1900    *:*                                    1856
  UDP    192.168.10.151:61564   *:*                                    1856
  UDP    192.168.10.151:64413   *:*                                    1680
  UDP    192.168.10.151:64724   *:*                                    1680
  UDP    [::]:123               *:*                                    1092
  UDP    [::]:500               *:*                                    424
  UDP    [::]:3702              *:*                                    1856
  UDP    [::]:3702              *:*                                    1856
  UDP    [::]:4500              *:*                                    424
  UDP    [::]:50829             *:*                                    1856
  UDP    [::1]:1900             *:*                                    1856
  UDP    [::1]:61563            *:*                                    1856


Posted on: 2011/3/3 0:33
Open in new window
Top
Re: FLServer port not binding under Windows 7

Joined:
2009/10/12 15:37
Group:
Registered Users
FLServer Admins
Posts: 46
Offline
The flserver is up and running just fine (just not bound to any listen port that works).

Here's a screen cap of the console of the server:


Attach file:



jpg  flservercon.jpg (477.55 KB)
1322_4d6ee28c2e633.jpg 727X1096 px

Posted on: 2011/3/3 0:36
Open in new window
Top
Re: FLServer port not binding under Windows 7
Starport Admin
Joined:
2009/2/21 21:42
Group:
Webmasters
Registered Users
Posts: 3505
Offline
This might be a stretch, but I see that you do not have an updated global list server. Try following these instructions: http://fllistserver.com/news/index.ph ... ancer-listserver/#more-72

Usually, you should be able to connect through LAN without the GLS, but maybe something's weird on your end and you could use the GLS as an alternative solution.

Posted on: 2011/3/3 0:39
"Cynicism is not realistic and tough. It's unrealistic and kind of cowardly because it means you don't have to try."
-Peggy Noonan
Top
Re: FLServer port not binding under Windows 7

Joined:
2009/10/12 15:37
Group:
Registered Users
FLServer Admins
Posts: 46
Offline
And here is the task list with the PIDs. I've completely uninstalled Symantec AV on this machine, and also done a clean W7 install with the same issues:


Attach file:



jpg  tasklist.jpg (252.34 KB)
1322_4d6ee3db5ba90.jpg 669X1112 px

Posted on: 2011/3/3 0:42
Open in new window
Top
Re: FLServer port not binding under Windows 7
Just popping in
Joined:
6/10 4:44
Group:
Registered Users
Posts: 1
Offline
I know this is an old post, but it helped me troubleshoot the problem. I may have a solution!!

I had the same difficulties, but with Windows 10 and even an old school Windows XP. So I created a bare install of XP SP1, no dice, the server would not keep listening on 2302. So that left only one thing...my network.

I tested different scenarios, while monitoring netstat, and found that if I set a static IP, the FLServer app will keep its binding on port 2302! I only set the IP and subnet, not the gateway.

I have several guesses as to what is going on, but unless I breakout Wireshark, I won't know for sure. I've already spent way too much time on this, so I'm gonna play while I can....

I hope this helps someone and saves them the 20+ hours of aggravation.

Posted on: 6/10 5:04
Top