Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
36 user(s) are online (14 user(s) are browsing Forum)

Members: 0
Guests: 36

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +30€

Current balance: -35€
(last updated 05/2019)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 40 users playing Freelancer on 41 servers.
May. 23, 2019

Browsing this Thread:   1 Anonymous Users



 Bottom   Previous Topic   Next Topic  Register To Post

(1) 2 3 4 »


Ehrm whats that?^^
Quite a regular
Joined:
2009/7/16 5:43
From Germany
Group:
Registered Users
Posts: 163
Offline
Hello Guys,

after some work and lots of help I've managed to make my ships flyable.
All was working fine until some minutes.
O bought a capital ship for testing, was shooting some NPCs and used some tradelines.
Then i came to a jumpgate, used it, spawned in the target system and yeah Server crashes.
Serverlog says:
Code:
E:\FL\Scratch\Source\Common\CEqObj.cpp(463) : *** WARNING: alloc_equip: Archetype[0x8000bec6] not supported/equippable!
(printed in yellow)
I searched for that code with FLDev, but nothing found.
And big G just give some topics with other main problems.

Maybe someone had the same Problem or an idea of a solution?

Posted on: 2009/8/1 15:40
Top
Re: Ehrm whats that?^^
Quite a regular
Joined:
2009/7/16 5:43
From Germany
Group:
Registered Users
Posts: 163
Offline
Ok LOL and sry for doubleposting

i pasted the CRC code wrong into FLDev >_>"

Now i find the critical entry: ge_lbd_engine_01

Code:
[Engine]
nickname = ge_lbd_engine_01
ids_name = 263889
ids_info = 264889
volume = 0.000000
mass = 0
max_force = 3000000
linear_drag = 100000
power_usage = 0
reverse_fraction = 0.100000
flame_effect = gf_li_largeengine02
trail_effect = gf_br_atransport_engine01_trail
trail_effect_player = gf_br_atransport_engine01_trail
character_start_sound = engine_li_freighter_start
character_loop_sound = engine_li_freighter_loop
character_pitch_range = -50, 25
rumble_sound = rumble_battleship
rumble_atten_range = -5, 5
rumble_pitch_range = -5, 5
engine_kill_sound = engine_li_freighter_kill
cruise_start_sound = engine_li_cruise_start
cruise_loop_sound = engine_li_cruise_loop
cruise_stop_sound = engine_li_cruise_stop
cruise_disrupt_sound = cruise_disrupt
cruise_backfire_sound = cruise_backfire
cruise_disrupt_effect = gf_li_cruisedisruption
cruise_charge_time = 5
cruise_power_usage = 0
indestructible = false
outside_cone_attenuation = -3
inside_sound_cone = 225
outside_sound_cone = 600


but everything looks fine towards me.

Posted on: 2009/8/1 15:52
Top
Re: Ehrm whats that?^^
Home away from home
Joined:
2008/5/13 15:48
Group:
Registered Users
FLServer Admins
$$$ Supporters $$$
Senior Members
Posts: 663
Offline
Try Lancer Solurus OUTSTANDING errorchecker
and the CRC Tool - i suppose thise: http://the-starport.net/index.php?option=com_tempdl&d=374 -
to check 4 those server error.

With the given info I d bet, one of the encounters (ie. one npc loadout ) in the system you entered is buggy.

Posted on: 2009/8/1 15:56
Open in new window
Top
Re: Ehrm whats that?^^
Quite a regular
Joined:
2009/7/16 5:43
From Germany
Group:
Registered Users
Posts: 163
Offline
Yeah see my second post^^

Now i tried it other systems, too (f.e. NY, O. Theta, Tau 31)
Everytime i spawn, jump or beam there the server crashes.
Even in a system without NPCs

And the only file containing "ge_lbd_engine_01" is the engine_equip.ini

Posted on: 2009/8/1 16:04
Top
Anonymous
Re: Ehrm whats that?^^
Anonymous-Anonymous
You sure it's not a banned item in the server software you are using?

Posted on: 2009/8/1 16:20
Top
Re: Ehrm whats that?^^
Quite a regular
Joined:
2009/7/16 5:43
From Germany
Group:
Registered Users
Posts: 163
Offline
No its not.

Now I've started FL (windowed mode) on the left screen and the server with console view on the other screen.
(long story without sence^^)
The message is printed while undocking.
Then i can fly around, shoot someone or smth. else.

But when i got killed and respawn + undock. Then the server say good bye.

Posted on: 2009/8/2 0:40
Top
Anonymous
Re: Ehrm whats that?^^
Anonymous-Anonymous
You say you start the server, is it just the server and no server software like Ioncross or FLHook? Reason i ask is if you have the 1.1 patch applied, you're using an engine that isn't normally for player use which is why you're getting kicked as it's on the banned item of goods. If you use Ioncross for instance, then you can set the engine to be useable and not get kicked everytime you use it. Try flying the ship with a standard engine like a Rheinland Freighter engine and see if you get kicked then

Posted on: 2009/8/2 8:39
Top
Re: Ehrm whats that?^^
Home away from home
Joined:
2008/12/26 16:55
From Xarania
Group:
Registered Users
Senior Members
Posts: 806
Offline
Or... make new one

Posted on: 2009/8/2 8:51
Open in new window
http://freexlr.forumotion.net - FL-XLR MOD http://www.smfweb.com/forums/MERCHQ - [MERC]
Top
Re: Ehrm whats that?^^
Just can't stay away
Joined:
2008/2/22 13:33
From that dark place in the back of your mind..
Group:
Registered Users
Senior Members
Posts: 330
Offline
Check the system your getting kicked in, see if you have any static capships (bases,wreck etc), as the usual cause of that error is having an engine in the solar loadout for those items.

Posted on: 2009/8/2 11:40
**shuffles of with a new headache**
Top
Re: Ehrm whats that?^^
Quite a regular
Joined:
2009/7/16 5:43
From Germany
Group:
Registered Users
Posts: 163
Offline
I've running FLHook 1.6.5, so i have 1.1 Patch.

And im not using the engine.
But now i make a new one like : wtf_dont_crash_engine_01
and put it into the special_loadouts.ini. (cause just there its used)

see ya later^^

/edit:

I did this and then:
Code:
E:\FL\Scratch\Source\Common\CEqObj.cpp(463) : *** WARNING: alloc_equip: Archetype[0xa91e7ec5] not supported/equippable!

.... 0xa91e7ec5 = wtf_dont_crash_engine_01



Posted on: 2009/8/2 17:55
Top
Anonymous
Re: Ehrm whats that?^^
Anonymous-Anonymous
Quote:

But now i make a new one like : wtf_dont_crash_engine_01
and put it into the special_loadouts.ini. (cause just there its used)


Ok, why would you put the engine there unless it's an npc ship? Are we talking npc ship or player ship? If player ship then it MUST GO IN THE GOODS.INI All flyable ship loadouts go in that file and nowhere else.

If it's an npc, then things are different. Obviously it would then go in the loadouts_special.ini.

Posted on: 2009/8/2 18:32
Top
Re: Ehrm whats that?^^
Quite a regular
Joined:
2009/7/16 5:43
From Germany
Group:
Registered Users
Posts: 163
Offline
i dont f***ing use this engine in any way. >.<
But it seems the Server do something with it.
Its in vanilla FL for the Liberty Dreadnoughts.
Its in every FL installation.

Posted on: 2009/8/2 18:45
Top
Re: Ehrm whats that?^^
Just can't stay away
Joined:
2009/6/17 9:13
From Hungary
Group:
Registered Users
Posts: 435
Offline
Quote:

Yeah see my second post^^

Now i tried it other systems, too (f.e. NY, O. Theta, Tau 31)
Everytime i spawn, jump or beam there the server crashes.
Even in a system without NPCs

And the only file containing "ge_lbd_engine_01" is the engine_equip.ini


If you get crash after jump, then i recommend to check the Missions/faction_prop.ini, and npcships.ini and cmp-shiparch-goods with Freelancer Error checker, i had same problems after jumping.
3DSound on/off?

Posted on: 2009/8/3 9:19
http://vnm51.deviantart.com/gallery/45865900/Freelancer
Top
Re: Ehrm whats that?^^
Home away from home
Joined:
2008/12/26 16:55
From Xarania
Group:
Registered Users
Senior Members
Posts: 806
Offline
Right.. on the Jumpcrash thing...

I had a bad prob with NY->TX .. went through it all.. tore out lots of hair..
All it was was 1 level of Outcast with a dodgy loadout trying to fire... that simple..

@ MoD.. Gibbs right m8.. no need to put anything "extra" in the loadout ini's
that's all for NPC's. Perfectly "legal" to have a player in the same ship with a differing engine than
the NPC's have ;D and wrong/strange data in the NPC loadouts will certianly crash FL well and good!

BTW.. hope its working well.. seems ye having fun with them 'eh.. hehe..

Posted on: 2009/8/3 9:34
Open in new window
http://freexlr.forumotion.net - FL-XLR MOD http://www.smfweb.com/forums/MERCHQ - [MERC]
Top
Re: Ehrm whats that?^^
Just can't stay away
Joined:
2009/6/17 9:13
From Hungary
Group:
Registered Users
Posts: 435
Offline
Quote:

Right.. on the Jumpcrash thing...

I had a bad prob with NY->TX .. went through it all.. tore out lots of hair..
All it was was 1 level of Outcast with a dodgy loadout trying to fire... that simple..

@ MoD.. Gibbs right m8.. no need to put anything "extra" in the loadout ini's
that's all for NPC's. Perfectly "legal" to have a player in the same ship with a differing engine than
the NPC's have ;D and wrong/strange data in the NPC loadouts will certianly crash FL well and good!

BTW.. hope its working well.. seems ye having fun with them 'eh.. hehe..


Yes mate same here with texas-ny, and more
@MoD: i have never tried server or multi and such, but if you can, then try this mod in open singleplayer. If you got crash there also, then not server problem.
The second, i dont know if it has a shield or not, but if it has then make sure the type of the shield is fits to the shiparch.ini and for npcs it does need to add "npc_" tag at the front of the shield type.
@Xarian: could you tell me which outcast loadout was buggy?

Posted on: 2009/8/3 9:39
http://vnm51.deviantart.com/gallery/45865900/Freelancer
Top
(1) 2 3 4 »