Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
31 user(s) are online (18 user(s) are browsing Forum)

Members: 0
Guests: 31

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +5€

Current balance: -45€
(last updated 09/2019)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 34 users playing Freelancer on 40 servers.
October. 17, 2019

Browsing this Thread:   1 Anonymous Users



 Bottom   Previous Topic   Next Topic  Register To Post



Hook 1.6.0 plugin p3
Not too shy to talk
Joined:
2010/1/4 7:47
Group:
Registered Users
Posts: 62
Offline
Habe folgendes Problem:
Ich möchte auf meinem Server die Plugin-Version von Flhook 1.6.0 verwenden. Dabei möchte ich auch die Cloaking-Funktion mit reinbringen. Jedoch lädt mein Hook nicht das Cloak-Plugin.(ERROR; could not load plugin) Kann mir jemand verraten, wie ich es zum laufen bekomme?
Infos: Habe die Content.dll im DLL/BIN Ordner mit der aus der 'Working_Cloak_096' Version ersetzt.
cloak.dll im EXE-Ordner vorhanden
cloak-plugin im plugin-Ordner
FlakCommon im pluginordner (ebenfalls ERROR)

Falls ich was an notwendigen Infos vergessen habe, dann einfach fragen.

Posted on: 2011/8/12 0:38
Top
Re: Hook 1.6.0 plugin p3
Just popping in
Joined:
2010/4/17 23:48
From Frankfurt
Group:
Registered Users
Posts: 17
Offline
Das Flak Common und das cloaking plugin sowie die anderen von Flak abhängigen Plugins sind nicht auf Vista/Win7 lauffähig es sei denn du stellt den kompatiblitätsmodus des FLServers auf Win98 was dir aber extreme Performanceverluste und regelmäßige Bufferowerflows bescheren wird. Eine weitere möglichkeit wäre eine VM für den Server einzurichten aber auch davon würde ich dir abraten die Leistungsverluste die du dadurch haben wirst rechnen sich nicht.

Eine möglichkeit von der ich aber nicht weiß ob es klappt ist das selbst kompilieren der Plugins sowie FLHook.
Kurz gesagt gibt es aktuell keine möglichkeiten cloaking mit der FLHook Plugin Version auf einem aktuellem Betriebssystem zu ermöglichen ohne Leistungsverlust oder ausreichende C++ Kentnisse.

Allerdings soll es im Discovery 4.86 eine möglichkeit zum cloaken geben dazu habe ich aber keine genauen Infos da hilft erstmal nur warten.

MfG Killerkeks

Posted on: 2011/8/12 1:45
Top
Re: Hook 1.6.0 plugin p3

Joined:
2010/6/15 2:11
From Germany
Group:
Registered Users
FLServer Admins
$$$ Supporters $$$
Posts: 23
Offline
@ Killerkeks

Die Aussage das der Flserver ( mit Hook ) unter Vista / Windows7 nicht läuft, ist falsch. Mach Dich doch mal schlau, bevor Du hier solche Tipps gibst. Naja...

@ anduriell

BTW. Schau Dich doch mal hier im Forum um, oder benutze doch einfach mal die Suche.
Es gibt genug Themen, die Deine Frage oder Fragen beantworten. Da kann man sich auch mal reinlesen.

Hier zum Beispiel : http://the-starport.net/freelancer/forum/viewforum.php?forum=29

Posted on: 2011/8/12 2:03
Open in new window
Top
Re: Hook 1.6.0 plugin p3
Not too shy to talk
Joined:
2010/1/4 7:47
Group:
Registered Users
Posts: 62
Offline
2erlei:
1. Ich habe mich schon durch diverse Beiträge durchgekämpft (mein Englisch ist eben nicht so gut), habe jedoch nichts in der richtung gefunden, was mir jetzt weitergeholfen hätte.
2. Habe auch schon Hook-Versionen gefunden, mit der ich auch cloaken könnte; die 'Working_Cloak_096', die aber auf dem Stand 1.5.5 ist. Und zum anderen die 1.6.5ff, bei den ich aber wieder den Kampf gegen Englisch hätte, um herauszufinden, wie ich diverse Zusäte wie Anticheatprogramme mit zum laufen brächte.

Gibt es da eine Möglichkeit an eine pluginbasierende Hookversion zu kommen, die unter Vista/7 läuft, ich als C++laie nicht noch was compilieren muss, und wo die Plugins auch laufen?

Posted on: 2011/8/12 8:37
Top
Re: Hook 1.6.0 plugin p3
Just popping in
Joined:
2010/4/17 23:48
From Frankfurt
Group:
Registered Users
Posts: 17
Offline
@Marcplanet: Bevor du wilde anschuldigungen durch die gegend schmeisst les richtig, es geht um die Flak Plugins für FLHook nicht um FLHook selbst.

@Topic: Du könntest im Plugin request Forum anfragen ob es breits jemand gemacht hat und die Plugins noch irgendwo rumliegen hat oder bereit wäre dir das zu machen.

MFG Killerkeks

Posted on: 2011/8/12 10:17
Top