Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
52 user(s) are online (30 user(s) are browsing Forum)

Members: 0
Guests: 52

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +10€

Current balance: -50€
(last updated 06/2019)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 65 users playing Freelancer on 34 servers.
July. 22, 2019
The Starport Forum Index > All Posts (J.R.)

Bottom Bottom   Previous Topic   Next Topic

(1) 2 3 4 ... 19 »


Re: Horizontal Tradelane Issues
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Hurray... hack works like a charm !

Thank you Xalrok. You realy made my day...

Greetings
J.R.

Posted on: 4/7 8:36
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: Horizontal Tradelane Issues
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Thanks for the nice hint Xalrok.
I did a search through the forums, but for some reason i didn´t stumble over this... :/

Very much appreciated !

I´ll try this hack and report in, after tests.

Greetings
J.R.

Posted on: 3/27 23:03
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Horizontal Tradelane Issues
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Hello folks.

I´ve been fiddling with horizontal oriented Tradelanes for a while. (left and right rings, instead of upper and lower)

So here is the Problem:
Lets say the first Tradelane i enter ingame is a standard one.
The activation-sequence and tunnel-animation will be displayed even on the other (horizontal model) so the tunnel and such is out of place. Even the NPCs use the standard upper and lower lane, although there are rotated to the left and right side in the second Tradelane they entered.

I already created an ADDITIONAL "basic_trade_lane_eq(_90)" in select_equip.ini to have a different appear of these lanes.
Tested this with the result:
The second type of animation will be displayed, when the "fist used" Tradelane calls this. After that, the other type of TL which calls the standard animation displays NONE of it.

With this in mind i assume:
If I use both Types of TLs in the game the "first used" animation-type will be displayed even on the other type of TLs (when using the same animation-call).
So it seems to be impossible to have both types of TLs without issues.

Is there a known way to prevent or fix this ?


Greetings

J.R.



Posted on: 3/23 9:40
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Building single-part-models out of multi-part-models
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Hi folks. <3
I´m looking for someone who is familiar with "converting a multi-part ship/station into a new SINGLE-PART-OBJECT.cmp" and its appropriate "MODEL.sur". This is desperatly needed for two of my models in ENIGMA V.4 ATG because of some minor bugs (how the server handles damage on multi-part-models).
Since these things do realy annoy me since AGES... ANY help would be VERY apprechiated.

To keep this post as short as possible:
Further details on the subject, as soon as there´s someone able/willing to help me with this issue...

Greetings

J.R.

Posted on: 2018/11/5 18:58
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: Need help with debugging
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Just a brainfart maybe:

I used to have the same issues when flying/mooring/docking a custom ship where the HPMount is pretty far from the nose of the model... so the model collides instead of reaching the dockpoint with its HPMount...
So I moved the Mount-HP in the model a couple of meters to the nose... Maybe this helps in your case too...

Greetings

J.R.


P.S.: Same result is available via raising the "docking-distance to reach" in the appropriate base-section in SolarArch.ini (see values behind the dock-hps)

Posted on: 2018/11/4 18:23
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: OpenGL Rendering
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Compared it with the previous examples and... Wow ! Looks very good man !
Well done @Schmackbolzen <3

THIS is the way it´s supposed to look like ! At least imho...

Greetings
J.R.

Posted on: 2018/8/28 12:08
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: Win 7 freelancer not working
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Suggestions:

1. DO NOT install Freelancer in "Program Files (x86)/Microsoft Games/Freelancer" but anywhere else.

2. Delete all save-games-files in your "my documents/my games/freelancer/Accts/SP" Folder. INCLUDING "restart.fl" !

3. Activate "DirectPlay" in your System-Settings (Windows-Legacy-Components)

4.Always run Freelancer with Administrator-Privileges

5. Check your AV-Settings for alerts or actions regarding Freelancer.exe and such...

6. Only if your Freelancer-Copy is the version that needs the CD in your optical drive: Replace the original Freelancer.exe with the NO-CD version (downloadable here on TSP).

Hope this helps...

Greetings
J.R.

Posted on: 2018/8/12 16:37
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: Another one failing by running Freelancer in Win 10
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Attached a zip with my flconfigdatbase.txt in this post...

Unzip it and copy the file into ".../Freelancer/EXE" Folder. This should fix the error-message regarding Graphics-Card. Let me know if it helps (at least with this particualar issue)

Greetings
J.R.

Attach file:


zip flconfigdatabase.zip Size: 10.26 KB; Hits: 49

Posted on: 2018/3/14 15:19
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: DALib Patch?
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Thank you @adoxa for clearings things up.

So its just a "fix" for singleplayer-issues.
I guess it wouldn´t be very helpful to ignore/skip those warnings in a Multiplayer-Mod since directplay is needed to connect with a multiplayer-server...

Greetings
J.R.

Posted on: 2018/3/11 7:12
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: DALib Patch?
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
I would love to have some more Info about this "Patch" as well.
Since SOME of my players running under WIN 10 experienced random crashs (client-side only) lately...
So maybe this DALib helps ???

Greetings
J.R.

Posted on: 2018/3/10 7:04
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: Nomads content pack
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
@Dromedary

Regarding "space_farclip" in System-inis:

I actually stumbled over some issues with it in the past... i.e: "Planets are suddenly fully visible through nebulas" when your ship isn´t IN the nebula (on the other side of it... but OUTSIDE of it) and the like... so maybe you should be a little bit careful with this entry in system-inis and doublecheck the effects ingame... Just a warm and friendly advice... <3

Greetings
J.R.

Posted on: 2017/12/19 19:50
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: have CD but have errors on noCD install window 10
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Have you tried to activate the "Legacy Components", "NET.Framework 3.5" and "DirectPlay" in the Windows 10 Settings ?

These issues are known as the most common problems under WIN 10.

Greetings
J.R.

Posted on: 2017/9/27 11:16
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: "Technical" use of the WeaponModDB-Entries in FL
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Quote:

corpse wrote:
Is the File server side editable ? ie clients will not need updating..


As far as I know the file is used serverside only (to calculate the damage)... but I didn´t do any testing on this, since the ini-file will be checked for cheating by the ENIGMA Mod-Launcher anyways on game-startup.

Greetings
J.R.

Posted on: 2017/8/20 20:57
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: Path crashes
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Maybe I´m totally wrong here, but there is only thing that comes to my mind:
So IIRC the paths need to have a starting and a endpoint "close" to a base or jumpgate/hole where (especially when bases are path-start/endpoints) the base-faction (in Mbases.ini) has to be at least neutral to the patrol-faction (in order to grant docking for the incomming patrol-NPCs).

But these are just my two cents...

Greetings
J.R.


EDIT: Just realized that this was allready covered by your own investigations... Sorry !

Posted on: 2017/8/20 20:34
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum


Re: "Technical" use of the WeaponModDB-Entries in FL
Just can't stay away
Joined:
2010/8/9 17:45
Group:
Registered Users
FLServer Admins
Posts: 321
Offline
Ah.. I see.
So it actually modifies the damage of the particular weapon-type when the shield got hit...meaning its not a "resistance-raise" but a "damage-reduce" by the given factor. In this case I should make it clear in my next update for the infocards, since the "damage-reduce-factor" is not equivalent with a "virtual capacity-raise". (as my example in the first post shows)

Thanks for clearing this up folks.
Much appreciated...

Greetings J.R.

Posted on: 2017/8/17 15:20
ENIGMA V.4 ATG HOMEPAGE/FORUM
Top
Topic | Forum



Top Top
(1) 2 3 4 ... 19 »



[Advanced Search]