Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login


Remember me

Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
68 user(s) are online (36 user(s) are browsing Forum)

Members: 0
Guests: 68

Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +0€

Current balance: 60€
(last updated 03/2020)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 52 users playing Freelancer on 40 servers.
May. 31, 2020
The Starport Forum Index > All Posts (Ancient)

Bottom Bottom   Previous Topic   Next Topic

Re: Getting a private LAN-flserver up and running..
Just popping in
2011/8/29 17:36
Registered Users
Posts: 4

lee0069 wrote:
It is your firewall mate. I had the same problem before.
Windows server 2008 has 2 firewalls 1 local and 1 public. your best bit is to disable it all together.

Hope this helps

Oh, this is news to me, i know you dont have t oin any way, but do you think you could describe the process of reachin the local and the public firewall ?

I am only familiar with the one you can find in the controlpanel lol.

I have had the same feeling about this that you say it could be for quite a while..

Point me in the right direction amte, it would be worth a fortune to me, i so miss playing this game properly

Posted on: 2011/8/30 8:19
Topic | Forum

Re: Getting a private LAN-flserver up and running..
Just popping in
2011/8/29 17:36
Registered Users
Posts: 4

Capt.Morgan wrote:
Does the server appear in your list at all? If so, is the IP odd looking? If it does, it sounds like you have an issue with IPv6. I wrote a tutorial on fixing that in Windows 7 (might work on others, too) on the Discovery forums here, and a couple other folks weighed in, too, so that may be worth a look.

If that's not it, then I don't really know what it would be. I'm sure somebody else here will be able to point you in the right direction, though.


First of all, thanks for the reply!

Yes i considered the IPv6, and used the microsoft FixIt to remove it, though it made no diffrence im afraid.

Oh and i might add, to make it less selfish, id be glad to enter the server in the online serverlists once i get it running.
It´s on a highend VPS so could probably hold quite alot of people.

Anyone else have any idea ?

(I just find it insane that it would work on my Vista computer, Vista that is usually considered a really annoying OS, and then not work on WindowsServer 2008.. Then again, WServer might be an even bigger pain in the ass, who knows )

Posted on: 2011/8/30 7:46
Topic | Forum

Re: Getting a private LAN-flserver up and running..
Just popping in
2011/8/29 17:36
Registered Users
Posts: 4
When comparing to my localmachine´s flserver cp all that is missing under that is:
Starting logic thread...
Server running, ready for log in.
Connecting to list server...

Thus, could it be i have missed a port or somthing like that ?

Posted on: 2011/8/29 23:07
Topic | Forum

Getting a private LAN-flserver up and running..
Just popping in
2011/8/29 17:36
Registered Users
Posts: 4
Hiya guys!

Its been quite a few years since last i was into this Freelancer thing, but every time i return i fall in love...

This time i even came up with the idea of hosting a server for me and my friends on my VPS.

Tried hosting on my local machine first and it worked out fine, no problems there, could connect ingame and such.

Now i moved it over to my rented VPS and blae, server wont start up properly..

All i get in the commandprompt is this:

Loading initial data...
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(1111) : NOTICE:General:Current DACOM.DLL version: 1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(1112) : NOTICE:General: Compiled against version: 1.11.173
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(852) : NOTICE:General:DACOM: initialize: dllpath: 'C:\Spel\FreeLancer\EXE\'
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(880) : NOTICE:General:DACOM: initialize: Loading DLL's from [Libraries] group.
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:General:DACOM: AddLibrary: DLL 'C:\Spel\FreeLancer\EXE\readfile.dll' [1.11.173]
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:General:DACOM: AddLibrary: DLL 'C:\Spel\FreeLancer\EXE\engbase.dll' [1.11.173]
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:General:DACOM: AddLibrary: DLL 'C:\Spel\FreeLancer\EXE\x86math.dll' [1.11.173]
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:General:DACOM: AddLibrary: DLL 'C:\Spel\FreeLancer\EXE\rendcomp.dll' [1.11.173]
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:General:DACOM: AddLibrary: DLL 'C:\Spel\FreeLancer\EXE\system.dll' [1.11.173]
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:General:DACOM: AddLibrary: DLL 'C:\Spel\FreeLancer\EXE\Thorn.dll' [1.11.173]
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:General:DACOM: AddLibrary: DLL 'C:\Spel\FreeLancer\EXE\DebugLib.dll' [1.11.173]
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:General:DACOM: AddLibrary: DLL 'C:\Spel\FreeLancer\EXE\rp8.dll' [1.11.173]
C:\work\builds\dalibs\dalibs-build\build\Src\DACOM\Dacom.cpp(618) : NOTICE:General:DACOM: AddLibrary: DLL 'C:\Spel\FreeLancer\EXE\shading.dll' [1.11.173]
C:\work\builds\dalibs\dalibs-build\build\Src\RenderPipeline\DX8\rp_dx8.cpp(763) : NOTICE:General:RenderPipeline
C:\work\builds\dalibs\dalibs-build\build\Src\System\SysContainer.cpp(291) : NOTICE:General:SystemContainer: LoadSystemComponents: Loading 'DirectX8' [] returned [OK]
C:\work\builds\dalibs\dalibs-build\build\Src\System\SysContainer.cpp(291) : NOTICE:General:SystemContainer: LoadSystemComponents: Loading 'MaterialLibrary' [] returned [OK]
C:\work\builds\dalibs\dalibs-build\build\Src\System\SysContainer.cpp(291) : NOTICE:General:SystemContainer: LoadSystemComponents: Loading 'TextureLibrary' [] returned [OK]
C:\work\builds\dalibs\dalibs-build\build\Src\EngBase\Engine\engine.cpp(508) : NOTICE:General:ENGINE::load_engine_components: aggregation of 'Animation' [] returned [OK]
C:\work\builds\dalibs\dalibs-build\build\Src\EngBase\Engine\engine.cpp(508) : NOTICE:General:ENGINE::load_engine_components: aggregation of 'Hardpoint' [] returned [OK]
C:\work\builds\dalibs\dalibs-build\build\Src\EngBase\Engine\engine.cpp(508) : NOTICE:General:ENGINE::load_engine_components: aggregation of 'RenderManager' [] returned [OK]

After that it just keeps on ...loading...... i tried pulling over the folder from my local to it and run of that to see if there was some install issue, but nope.

Opened up the whole portrange for flserver aswell.

Oh, my localmachine runs WindowsVista
and my VPS runs Windows Server 2008.

It is a clean copy of FL ver 1.0

I got all other games i tried to run properly thus far, so i dont see why this should run aswell..

If anyone got any ideas about this, that could possibly result in me getting this server running, i will be in debt to you forever, hell ill be the guy mixing margaritas at ur wedding.

Best regards // Ancient

Posted on: 2011/8/29 22:38
Topic | Forum

Top Top

[Advanced Search]