Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +30€

Current balance: -190€
(last updated 04/2017)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Thanks!
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
26 user(s) are online (7 user(s) are browsing Forum)

Members: 2
Guests: 24

Treewyrm, SWAT_OP-R8R, more...
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 114 users playing Freelancer on 46 servers.
April. 23, 2017

Browsing this Thread:   1 Anonymous Users



 Bottom   Previous Topic   Next Topic  Register To Post



New Tokyo System crash in Shattered Worlds 1.65 OSP
Just popping in
Joined:
2016/5/10 22:43
Group:
Registered Users
Posts: 3
Offline
Hello,
Sorry if it's bad form for my first post to be "help me I'm dumb", but I'm running out of places to look for a solid answer.

I downloaded the Shattered Worlds 1.65 release from moddb and everything was going fine for a few hours. But once I got to the New Tokyo system, I started getting CTDs when either
1) Docking with a Trade Lane. My ship would approach and enter, but just before the jump started(when the screen gets bright, a second or two after the gate "turns on" ) or;
2)Launching my ship from a station in the system, after getting there by cruise engines instead of the gate. Docking with the station was fine..But I couldn't leave!

I looked through several pages of search results on the forum for various crashes. It seems like crashing at ship launch is somewhat common, but that doesn't appear to be the issue I'm having given that it's only happened in New Tokyo so far.

I found This Thread which sounds extremely similar to my problem, however it doesn't seem to be a general Kusari space problem in my case - again, only New Tokyo.
Trade Lanes and launching from bases was fine in the Honshu system and everywhere else I've been so far, though that's mostly been Rhineland and Liberty.

Anyone know whats going on here, or whether or not other systems have this problem? I'd like to keep playing this save and not downgrading(1.5 doesn't advertise Open SP either far as I can tell), so if this is only a New Tokyo problem I can just stay away and deal with it. But I don't want to keep playing this version if it's going to happen in several other systems, either.
Does that old thread still apply? Or was it fixed by 1.65 and this is an issue on my end?

Thanks, I'll appreciate any insight into this.

Posted on: 2016/5/10 23:18

Edited by Durdan on 2016/5/11 1:38:39
Edited by Durdan on 2016/5/11 5:56:42
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Not too shy to talk
Joined:
2014/5/12 18:49
Group:
Registered Users
Posts: 100
Offline
post the error code your server generated
also have a look on your root drive there should be a log from the server, maybe you can nail the bug this way.

trade rings must be in sequential order or you crash the server on docking.
undock crash maybe due to crashy npc spawns ?(check encounter values do not exceed 100%) did you always crash the server on exit ?

Posted on: 2016/5/11 0:04
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Just popping in
Joined:
2016/5/10 22:43
Group:
Registered Users
Posts: 3
Offline
Quote:

corpse wrote:
post the error code your server generated
also have a look on your root drive there should be a log from the server, maybe you can nail the bug this way.

trade rings must be in sequential order or you crash the server on docking.
undock crash maybe due to crashy npc spawns ?(check encounter values do not exceed 100%) did you always crash the server on exit ?

Thaaaat won't be necessary. Figured out what it was, I think.

I was able to leave the station I was stuck on, and also enter a trade lane without crashing.
One of two things, did them both but I'm assuming the first is what did it:
1) I had to apply Adoxa's MP3 Codec to the Shattered Worlds /EXE folder in FLMM - I only had it applied to the vanilla Freelancer/EXE folder or;
2) Un-equiping my ships Thruster and Shield Generator, (successfully) leaving the base, redocking, re-equiping, and launching again

Again, 1 seems the most likely. My FLspit log was littered with the MP3Codec issue. Didn't know I needed to apply it to the mod folder as well.
Really weird that an audio codec problem caused those crashes only in one specific sector, though. I don't get it, but I'm not going to question it if it works.

Thanks for the reply and attempt to help anyway, Corpse. Hopefully this fixed the issue entirely for any other sector it might have happened at.

Edit: Oddly, it came back at Shinigawa station. But, buying a new ship fixed it yet again... I don't even know whats going on anymore. I've had that ship(Civilian Miner from Pittsburgh) since almost the start of the game. Why that would be causing a crash on undocking from specific stations is beyond me. Now I'm worried I haven't squashed the bug, merely fixed it in one location. If this ship starts having issues in another system and I don't have the funds to buy a new ship at that base, I'm screwed.
This is downright bizarre.

Posted on: 2016/5/11 1:37

Edited by Durdan on 2016/5/11 3:37:16
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Not too shy to talk
Joined:
2014/5/12 18:49
Group:
Registered Users
Posts: 100
Offline
try turning 3d sound off.
post the error codes.

Posted on: 2016/5/11 11:33
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Home away from home
Joined:
2008/5/21 19:32
Group:
Registered Users
FLServer Admins
$$$ Supporters $$$
Senior Members
Posts: 838
Offline
I'm not familiar with Shattered Worlds. It's possible that the mod has some issues that are not compatible with single player.

I've found CTD's like that are often caused by NPC encounters. If the pilot isn't configured properly for example, encountering that particular NPC group can cause a CTD, especially when you're crashing in space.

As has already been mentioned, if you're experiencing the CTD when entering a tradelane it could be either an NPC encounter, or an incorrectly configured tradelane. The latter especially if it's always that tradelane and only that tradelane.

I thought the MP3codec issue was more of a nuisance in the error logs than an actual game-affecting problem.

Finally, if you're playing the mod on a multiplayer server also running that mod, if there's an incompatibility between the version on the server and the version on the client, that would also be an issue. Make sure the same version is being run on both ends. If you're playing the mod on a server that's NOT also running that mod, that would be a problem as well.

You could always try completely reinstalling FL and re-activating the mod. The issue could be caused by detritus from a previously activated/deactivated mod.

Posted on: 2016/5/11 12:11
Gun control is like fighting drunk driving by making it harder for sober people to buy a car...
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Just popping in
Joined:
2016/5/10 22:43
Group:
Registered Users
Posts: 3
Offline
3D Sound is already off.

I did a clean install and still experienced the inconsistent crashing leaving Shinigawa Station. Oddly, now when I try to run FLspit after the re-installation it's saying it can't find a spew file, despite the crashes still happening. If you know how I can get FLspit to read the file again I'll try to get a fresh error log.

But I entered this string in Google prior to the re-install, so maybe this will suffice:

Code:
WARNING:General:set_gamma_function() called outside of create buffers/destroy buffers
WARNING: Failed to get start location
ERROR:General:StreamingSound: missing MP3 codec?
ERROR:General:StreamingSound: missing MP3 codec?
ERROR:General:StreamingSound: missing MP3 codec?
WARNING:General: DA SYSTEM: trailing references
WARNING:General: DA SYSTEM: trailing references


From Windows Event Viewer:
Code:
Faulting application name: Freelancer.exe, version: 1.64.0.0, time stamp: 0x00534d69
Faulting module name: Content.dll, version: 1.0.1254.11, time stamp: 0x3ecbb142
Exception code: 0xc0000005
Fault offset: 0x000c458f
Faulting process id: 0x1e0e0
Faulting application start time: 0x01d1ab2e3905b4bf
Faulting application path: C:\Games\Freelancer\EXE\Freelancer.exe
Faulting module path: C:\Games\Freelancer\dlls\bin\Content.dll
Report Id: 986b95c5-1721-11e6-bee9-6036dd6e8777
Faulting package full name: 
Faulting package-relative application ID: 

Not sure why it says 1.64.0.0, the mod according to Moddb is 1.65 - the last upload of it.

Sorry, but that's all I have of it right now.

One thing I'm noticing is how inconsistent its being when leaving the station.
The posts here combined with what I got when I google searched that FLspit fragment above made it sound like it just might be a NPC issue. The ships that spawn to fight when you leave the station, or something. Though that doesn't explain why entering a trade lane would lead to it - doesn't it only spawn ships when the lane is disrupted or you leave it? Not enter?

Regarding server logs, does that apply to my problem? I'm playing Open Single Player, not hosting a local multiplayer server or anything. Open SP replaces the New Game button in the games Main Menu and doesn't involve using the FLServer application or entering multiplayer. Far as I know anyway, maybe I'm doing it wrong. I'm also not sure how those differ from the normal error logs, if they even do. So I'll need information on how to find it if it is required.

I've kind of given up on Shattered Worlds OSP and just reinstalled X3:AP, haha. But if any of you have more trouble shooting ideas I'll still give them a shot and test them out, just to figure this out.

Edit: To note, too, it's not limited to this single trade lane. It's all over the New Tokyo sector.
Also, taking the Jump Gate back to Honshu worked fine, but taking the Jump Gate to the north of the Honshu one in New Tokyo caused a crash on entering it. Not sure what that means, but it may help.
I haven't landed on any other station or planet in New Tokyo besides Shinigawa as I just assume the entire sector is an error waiting to happen, but if you need me to check I can go land on and try to launch from other docks there, but my moneys on it being the same deal.

Posted on: 2016/5/11 17:17

Edited by Durdan on 2016/5/11 17:22:17
Edited by Durdan on 2016/5/11 17:29:12
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Home away from home
Joined:
2008/5/21 19:32
Group:
Registered Users
FLServer Admins
$$$ Supporters $$$
Senior Members
Posts: 838
Offline
You could try remarking out all encounter lines in the system in question and see if the problem goes away. If it does you can start reactivating each encounter until the problem recurs.

Then you've found your culprit. From there it's just a matter of making sure the npc properties for that faction are set up properly.

Also, make sure that each encounter is identified up at the top of the system ini.

Posted on: 2016/5/12 1:57
Gun control is like fighting drunk driving by making it harder for sober people to buy a car...
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Not too shy to talk
Joined:
2014/5/12 18:49
Group:
Registered Users
Posts: 100
Offline
i would stat by commenting out encounters then see if your still crashing. just comment out
Code:
faction = blah

then you can start adding them in singularly.

crashing leaving a station ? "WARNING: Failed to get start location"
check the base has
Code:

base = "the base id" < it will be like ku01_05_base >
dock_with = "the base id"


crashing on jumpgate
try deleting ,,DATA\Universe shortest_illegal_path.ini, shortest_legal_path.ini, systems_shortest_path.ini.
now start flserver.exe and it will rewrite these files for you.

try turning 3d sound off you may have to use a hack
"freelancer.exe, 02B6CB, 04->00, disable 3D sound (ignores the value of USE_3D_SOUNDS, always using 0)." Andoxa

get a copy of fl error checker and flscan
use these two too discover files errors that lead to crashes, ie bugged npc ships, missing files etc..




Posted on: 2016/5/12 11:04

Edited by corpse on 2016/5/12 19:28:59
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Just can't stay away
Joined:
2008/2/28 12:30
From Trade Lane Watching
Group:
Registered Users
FLServer Admins
$$$ Supporters $$$
Senior Members
Posts: 440
Offline
If Foresaken doesn't reply in a couple of days, I'll try to contact him on Steam, tell him about this and hopefully, he can provide some sort of resolution.


Too bad their server's not running anymore. It was a good one and this is a great mod.

Posted on: 2016/5/13 0:15
Open in new window
Freelancer, 134 years old and still playing the game.

Is Juni here?
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Home away from home
Joined:
2008/2/17 23:14
Group:
Registered Users
FLServer Admins
Senior Members
Posts: 518
Offline
Hey guys, Hunterkiller asked if I could pop my head in here.

It definitely sounds like an encounter issue. I quit modding after version version 1.3 and turned it over the the rest of the guys... so I don't know what channels happened in 1.65. I do know for a fact that 1.3 worked with OSP (well there was a way you could break it if you cruised faster than normal).

The easiest way would to grab a copy of the 1.3 encounters and do a quick compare. If you cannot find them, I would remark all the encounters out and add them in one by one until you get an issue and start digging from there. I'm sorry I am not more help. I quit modding in 2010 and don't remember much. :*(


Posted on: 2016/5/16 23:46
Open in new window
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Just can't stay away
Joined:
2008/2/28 12:30
From Trade Lane Watching
Group:
Registered Users
FLServer Admins
$$$ Supporters $$$
Senior Members
Posts: 440
Offline
Hiyas FS, I see you got my message. Good deal.

Posted on: 2016/5/19 15:16
Open in new window
Freelancer, 134 years old and still playing the game.

Is Juni here?
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Not too shy to talk
Joined:
2014/5/12 18:49
Group:
Registered Users
Posts: 100
Offline
just a thought here, is the mod using custom ships ?
if so your problem may be with wrongly configured .sur files.
make sure that the thruster, ecm, and mine are listed in the ships sur file, use Adroxa`s flmodel tool to see the file data, also i have seen crashes from projectile weapons so check meshes and .sur files.
On a server you can patch against these crashes in sp i am not sure if you are able to capture them.

Posted on: 2016/5/19 16:20
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Home away from home
Joined:
2009/9/28 21:13
From Wales
Group:
Registered Users
Senior Members
Posts: 924
Offline
The answer lies in the thread linked to in the OP. Don't waste time scratching your head for other possibilities, just run flscan2, it's a good tool so make use of it, you'll see the encounters in kusari are a total abortion.

Use SWWT v1.5 instead, it's a great mod. Later versions weren't intended for SP, the changes to factions were made to reflect the state of play on the server, and unfortunately they were poorly executed.

Posted on: 2016/5/20 2:00
Top
Re: New Tokyo System crash in Shattered Worlds 1.65 OSP
Not too shy to talk
Joined:
2014/5/12 18:49
Group:
Registered Users
Posts: 100
Offline
Thanks timmy51m "encounters in kusari are a total abortion".

Posted on: 2016/5/20 12:29
Top