Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
52 user(s) are online (27 user(s) are browsing Forum)

Members: 0
Guests: 52

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +30€

Current balance: -190€
(last updated 04/2017)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 34 users playing Freelancer on 38 servers.
September. 25, 2017
The Starport Forum Index > All Posts (Cpt_Rei_Fukai)

Bottom Bottom   Previous Topic   Next Topic



Re: Crash Offsets
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
Server crash in Content.dll at 000db0f1:
It happens when you try to spawn a patrol encounter inside of a population zone that is not a patrol path.

Posted on: 9/16 12:33
Top
Topic | Forum


Re: Path crashes
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
I commented them out, but it still crashes at the same offset.

Since my 'mod' will be open source anyway I attached a zip with code excerpts. I hope I got everything relevant. The system file is of course not complete, but it works and still crashes the server at the same offset.

Attach file:


zip Iw07.zip Size: 10.28 KB; Hits: 21

Posted on: 8/28 20:49
Top
Topic | Forum


Re: Station textures not visible
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
Works on my machine

Minor Errors I've found:
-The texture is called tga but is actually a dds
-If the model consists only of one group it should be a .3db
Major Error:
-The Hardpoint node is empty. Use UTF-Editor or the XML-Project to delete the Hardpoint Node/add Hardpoints. After that you should be able to see it ingame like in my picture.

Attach file:



jpg  babylon_station.jpg (105.26 KB)
46303_59a46f115f31e.jpg 501X367 px

Posted on: 8/28 20:29
Top
Topic | Forum


Re: Path crashes
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
Quote:

robocop wrote:
Just for interest, try running the mod through FLErrorChecker and FLScan.

The only thing FlscanII finds are four duplicate encounters, because I spawn the same encounter with different difficulties in the same zone.
Quote:

Also, do you have any paths that are labeled identically? Or nicknamed identically?

The nicknames are unique, some labels are the same because the path has two parts, but the numbers differ of course.
Quote:

Finally, do the encounters exist in the system ini and in the ENCOUNTERS folder? Also, are the encounters themselves formatted properly?

All encounters on the patrol paths are from vanilla and are referenced on top of the system.
Quote:

Thought of something else...
Are you sure the only change you made was to the base reputation? Is the base populated by the faction that you changed the reputation to?

Also, go back to a working version of the mod and then change a section. Then test before you move on to the next section.

Sometimes it's something as simple as an accidental keystroke that changed something important.


I changed the whole [MBase] entry when I swapped the faction. The new entry is a copy of a vanilla base with custom ID-strings. I don't want to change it back though.

Posted on: 8/25 8:44
Top
Topic | Forum


Path crashes
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
Greetings,

I am having trouble with the patrol paths in the system I built, it all started when I changed the reputation of one base from fc_lh_grp to fc_c_grp.

Since then, all patrol paths in my system crash at Content.dll 000c458f and I can't seem to find the bug.

Sample Path:
Code:
[Zone]
nickname = Iw07_path_Werft_Rh04
pos = -3000, 0, 2100
rotate = -256, -57, 0
shape = CYLINDER
size = 800, 6000
sort = 99
toughness = 17
density = 9
repop_time = 30
max_battle_size = 10
pop_type = trade_path
relief_time = 20
path_label = co_khc_01, 2
usage = trade
mission_eligible = false
faction_weight = rh_n_grp, 10
faction_weight = co_rs_grp, 3
faction_weight = co_khc_grp, 3
encounter = area_trade_trader, 17, 0.0400000
faction = co_rs_grp, 0.500000
faction = co_khc_grp, 0.500000
encounter = patrolp_gov_patrol, 17, 0.0400000
faction = rh_n_grp, 1.000000


I've been digging the forum for solutions, but I was unsuccessful/did not find an explanation where to serach for the bug.

Relevant Threads/Posts I found:
Forum1
Forum2

Since I have only have this system I would prefer to fix the problem, rather than change reputations or hack around it, but I don't know what to fix.

Posted on: 8/20 17:52
Top
Topic | Forum


Re: "Technical" use of the WeaponModDB-Entries in FL
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
It is not only a damage reduction, it is possible to create a weapon that deals bonus damage against certain shield types, like in the example I put in the wiki.

Posted on: 8/17 21:13
Top
Topic | Forum


Re: "Technical" use of the WeaponModDB-Entries in FL
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
I have written a wiki article on this topic two months ago, I hope it covers all your questions, if not, then don't hesitate to ask:

weaponmoddb.ini

This is only based on my observations, I didn't look at the code.

Posted on: 8/16 21:45

Edited by Cpt_Rei_Fukai on 2017/8/16 22:53:21
Top
Topic | Forum


Re: Librelancer 2017.03
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
Well, the physics in Freelancer are a lot like flying an airplane rather than a ship in space.
That means that every force has a counter force and that's why you stop if you turn off your engine (not engine kill!).
So the standard physic equations for speed, distance and acceleration, etc. apply to FL.

I've added some info regarding engines and thrusters to the wiki, so head over if you got any questions. I'll write something on ship handling in the next weeks.

Posted on: 6/28 18:35
Top
Topic | Forum


Re: UTF Editor
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
I'm not sure I understand your question correctly. Does Freelancer display the textures correctly and UTF-Editor doesn't? And what do you mean by it shows no color, is the model displayed completely white or what?

Posted on: 6/25 21:09
Top
Topic | Forum


Re: Crash Offsets
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
Crash in Common.dll at 000f20e3

It happened because of bad thruster model, which for some reason doesn't appear mounted on the ship(I've yet to find out why).
If your ship gets gets destroyed, FL will try to destroy the thruster and crash. This will probably happen with other equipment, too.

Posted on: 6/10 20:45
Top
Topic | Forum


Re: Question: Animating CMP files?
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
Hi there,

well, Freelancer supports two different animations, sliding animations called pris and rotations called rev.

And I think that groups that are a child of another group move together with the parent group.

I've done what you want to do, but afaik the only .cmp exporter fhat suppoerts animations is for 3dsmax.

If you want to do it with blender like I did, I think the only possible way is to use a cmp exporter and adoxas XML-Project to animate it manually.

Posted on: 6/3 19:21
Top
Topic | Forum


Re: Sur position problem
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
Well I'm with Treewyrm on this one, the Position/Offset data for the doors is probably the cause of your problem.

@FriendlyFire: It works well with all the surs I have created so far. Attached is a picture of my animated jump gate.

Attach file:



jpg  akeela_tor.jpg (135.60 KB)
46303_5908f60105a86.jpg 500X421 px

Posted on: 5/2 22:12
Top
Topic | Forum


Re: UTF Editor
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
So I just tried out the new version and everything looks good.

The shield .surs also display correctly, if you rename them to match the filename of the cmp.

Attach file:



jpg  shield_sur.jpg (67.87 KB)
46303_58bb28c2e8c99.jpg 500X512 px

Posted on: 3/4 20:38

Edited by Cpt_Rei_Fukai on 2017/3/4 20:48:52
Edited by Cpt_Rei_Fukai on 2017/3/4 20:51:26
Top
Topic | Forum


Re: UTF Editor
Just popping in
Joined:
3/1 17:22
From Bavaria
Group:
Registered Users
Posts: 14
Offline
An option to view shield .surs would be nice as well

Posted on: 3/1 17:31
Top
Topic | Forum



Top Top



[Advanced Search]