Freelancer Community Network
Reminder: Internet Explorer 6 or below are NOT supported.
HomeHome
ForumForum
WikiWiki
DownloadsDownloads
ForgeForge
Multiplayer Connection Tutorial
Collapse/Expand Random Image
Collapse/Expand Login
Username:

Password:

Remember me



Lost Password?

Register now!
Collapse/Expand Chat
Collapse/Expand Who's Online
29 user(s) are online (17 user(s) are browsing Forum)

Members: 0
Guests: 29

more...
Collapse/Expand Donations
Monthly costs: -30€
Income (ads): +5€
Donations (last month): +30€

Current balance: -190€
(last updated 04/2017)

Please make a donation if you want to help keeping The-Starport online:

Bitcoin address:
Thanks!
Collapse/Expand Links
Collapse/Expand Advertisement
There are currently 25 users playing Freelancer on 39 servers.
August. 17, 2017
The Starport Forum Index > All Posts (ColdFire)

Bottom Bottom   Previous Topic   Next Topic

(1) 2 »


Re: Random System Generator

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
Hi,
It is an interesting tool you did... Very suited for new modders IMO.
Would it be possible to also add some patrol generation (if there's not) ? Even with dummies populations, just to understand how it is made ?

Many thanks for your work, I'll test it soon (missing some free time recently ^^) !

Posted on: 2012/3/13 12:30
Top
Topic | Forum


Re: Looking for a X-Wing

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
The easiest method I'm thinking if you don't know how to mod ships or equipement files :

Code:
75-->EB  freelancer.exe  080942  M0tah  allow engines to be sold
0F85-->90E9  freelancer.exe  0808AD  adoxa  allow engines to be transferred 


It will allow you to sell one of the engine. Be carefull, in your mod, there's no engine for sale, so if you sell the 2 engines, you will have to buy another ship

Posted on: 2012/3/13 11:49
Top
Topic | Forum


Re: [almost resolved] Planet modding

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
@Alucard : I don't seem to have this problem. Maybe it is because I'm using TGA rectangular textures, with sphere mapping option (as opposed to default mapping like it seems in the tutorial)
Edit : just checked again, I don't think I have the problem you described. My textures are made with gimp, tga no compression, no alpha channel on the surface, scaled down to 4096x2048, mirrored vertically and horizontally, sphere mode in ms3d.

@Timmy : I'm using TGA 4096*2048 textures because after testing with dds (square) and tga, tga finally looks better (50% superior resolution, and my mercator texture is less 'stetched' on the poles with rectangular tga). On a side note, I don't have a problem with tga textures filesizes, as my mod is not meant to become largely public.

@Silent : Thanks for the advice, this one was the first working version, I plan to make tests with other settings on the clouds. Using different models for the different layers allows me to apply different effect on each layer, it was the point.
I would like to also make the surface a little more reflective and the clouds diffuse the light of the cities glowmap behind it.
I will try with 3ds.
About this, what is the difference between cmp and 3ds ? I note cmp are often being used in models and 3ds are being used for icons and small solars, but why ?

Edit : btw, I'm using these nasa maps for my textures. Maybe it will be useful for someone.

Edit #2 : a wild idea... Is it possible to use bumpmaps in FL ? And if yes, is it possible to use bumpmap + glowmap on the same model ? I just found a very good earth bumpmap....

Edit #3 : using my technique I notice something strange : I applied different spinning speeds to the different layers, but the surface is the only one which keeps spinning after a while. I already changed the spinning offsets, and it resolved my 'single model planet' spin issue (stopped after a few seconds).

Posted on: 2012/3/13 11:39

Edited by ColdFire on 2012/3/13 11:55:40
Edited by ColdFire on 2012/3/13 11:58:03
Edited by ColdFire on 2012/3/13 12:03:28
Edited by ColdFire on 2012/3/13 12:11:52
Top
Topic | Forum


Re: Looking for a X-Wing

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
You're welcome.
For old mods versions, you could also check here
I'm currently mirroring this database just in case, 22Gb full of mods so far...

Posted on: 2012/3/10 12:01
Top
Topic | Forum


Lights down and sound up...

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
Hi,
You may have seen it already, but it is one of the best footages I've ever seen on the web :

(watch it in HD on the original youtube page)

If you have other footages of this kind, feel free to share

Have a nice and lovely day !

Posted on: 2012/3/10 1:59
Top
Topic | Forum


Re: Looking for a X-Wing

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
Hi, I have a rebel X-wing available in my shipyard.
You can find it attached to this post. I think I may have other variations, I will check.

If you need something else, I have backups of everything I downloaded since 2003 (+40Gb mods, tools, models, tutorials, etc...)

Have fun !

Attach file:


zip xwing.zip Size: 779.34 KB; Hits: 327

Posted on: 2012/3/9 17:47
Top
Topic | Forum


Re: Planet modeling help

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
Ok, after re-doing everything from the start, the second method is now working : 2 different models, one for surface+glowmap, the second 10% larger for the atmosphere (but without a sur, not needed).
Here is the result, with the original tutorial glass texture :
Open in new window
Not so bad, but needs some tweaking.

I think my problem was due to working blind inside milkshape without experience with it, my models being too large for the software (isn't there a workaround about this ?)

I still don't know why I wasn't able to render the 2 models on the same time yesterday... Now the exact same technique is working... Go figure !

EDIT :
one step further... need to work on the alpha channel to reduce the aliasing effect.
Open in new window
Next one will be with a 3rd model for the atmosphere layer...

(edit for a new screenshot, in HD res, I wanted to see the previous result on a good pc :p)
Open in new window

Posted on: 2012/3/9 10:52

Edited by ColdFire on 2012/3/9 11:01:17
Edited by ColdFire on 2012/3/9 13:06:50
Edited by ColdFire on 2012/3/9 13:08:12
Edited by ColdFire on 2012/3/9 18:14:52
Top
Topic | Forum


[almost resolved] Planet modding

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
Hi,
I just started working on my planets.
With this great tutorial and this one, I am now capable of creating a new cmp planet model (the first thing I make in milkshape ^^), scale it to the size I want, apply my high def texture to it, and finally add glowmap to the mat. Everything is very nice, I'm more than happy about this part :
Open in new window

Except are missing the atmosphere effect and the clouds layer.

So with the help of this tutorial, I'm trying to add the atmosphere layer. Problem is : the model provided with the tutorial has far too low poly counts for my enormous planet. It is working, but it is very angular and ugly.

So, I tried the whole evening to reproduce the tutorial model but with a lot more polys (99*99, scale 100000 for the surface layer), and I go nowhere. The best I can achieve is this :
Open in new window
The 'tube' you see in the middle seems to be the atmosphere layer, the surface layer is completly cut... Not so good, isn't it ? ^^

I say again, I'm a total noob with modeling / texturing. All I can do well is creating glowmaps xD
So, is there anyone with enough will and time to reproduce the tutorial model for me, but with 99*99 polys for surface and atmosphere layers ?
Or at least, could someone please explain how I could do it myself ?

Thanks

EDIT
Ok, I tried to take another route to do it, and I think I noticed something weird.
I'm trying to make a cloud layer using a second model, a little bigger than the 'surface' model, and using the alpha channel technique of the second tutorial.
I can render the 'clouds model' fine, but only if I remove the surface model from the map. I tried to make 2 differents 'planets' for the test, not at the same position, but the clouds one doesn't seem to render if the surface one is present. I can select it, so the sur is ok. As soon as I remove the surface planet, the clouds one appears where it is supposed to be, with the right transparency.
Open in new window

I cannot use transparency and glowmapping at the same time, or something like that ? I repeat, i'm totally noob to this

Posted on: 2012/3/9 0:46

Edited by ColdFire on 2012/3/9 3:32:43
Edited by ColdFire on 2012/3/9 3:33:28
Edited by ColdFire on 2012/3/9 3:36:25
Edited by ColdFire on 2012/3/9 13:27:10
Top
Topic | Forum


Re: Q-Place new base into a system

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
The only thing I can tell you about mBases.ini :
A base start with [Base] and ends just before the next [Base]
When I want to remove old bases leftovers, I just search for the base ID to remove (ie : NE01_01_base) and remove everything between [Base] and the next [Base]

Other than that, I cannot help you about mBases.ini as I usually don't mess with it (except correcting errors / removing old bases)

Posted on: 2012/3/8 13:14
Top
Topic | Forum


Re: Q-Place new base into a system

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
Hi,
I think it would be more easy to add a new base with the right dealers than adding a shipdealer to an existing base.
For that you'll need the Freelancer Explorer tool. It is graphical and very easy to play with for this kind of stuff.

Add a new base to the system and choose an existing base template where the shipdealer is present.
Then, add everything you want to the base. FLexplorer can do that for you, but personnaly I prefer doing it at hand. You seem to know how to do that part.

Good luck with your mini-mod !

Posted on: 2012/3/6 22:44
Top
Topic | Forum


Re: FLScanII

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
Hi, I tried it too, and I'm having errors.
My mod certainly contain real errors, so I'll try to report only execution errors or those I don't understand :

Code:
[error] An error happend while parsing. The scan can't continue. 'La méthode ou l'opération n'est pas implémentée.'   à FLScanIE.EquipmentChecks.ParseGoodFile(String file, List`1& goodNicknames)
   à FLScanIE.EquipmentChecks.ParseEquipmentFolder()
   à FLScanIE.Checker.Parse(String flPath)

(the method or operation is not implemented)

Code:
[error] An error happend while checking loadouts 'La valeur ne peut pas être null.
Nom du paramètre : source'   à System.Linq.Enumerable.Contains[TSource](IEnumerable`1 source, TSource value, IEqualityComparer`1 comparer)
   à System.Linq.Enumerable.Contains[TSource](IEnumerable`1 source, TSource value)
   à FLScanIE.EquipmentChecks.EquipExists(String nick)
   à FLScanIE.LoadoutChecks.CheckLoadoutFile(String file)
   à FLScanIE.LoadoutChecks.CheckLoadouts()
   à FLScanIE.Checker.RunCheck(CheckDelegate check, String name)

(I don't understand the problem or what to look for)

Code:
[error] An error happend while checking ships 'La valeur ne peut pas être null.
Nom du paramètre : source'   à System.Linq.Enumerable.Contains[TSource](IEnumerable`1 source, TSource value, IEqualityComparer`1 comparer)
   à System.Linq.Enumerable.Contains[TSource](IEnumerable`1 source, TSource value)
   à FLScanIE.EquipmentChecks.EquipExists(String nick)
   à FLScanIE.ShipChecks.CheckShip(String file, Section ship)
   à FLScanIE.ShipChecks.CheckShipFile(String file)
   à FLScanIE.ShipChecks.CheckShipFolder()
   à FLScanIE.Checker.RunCheck(CheckDelegate check, String name)

(same)

Code:
[error] An error happend while checking equip 'La référence d'objet n'est pas définie à une instance d'un objet.'   à FLScanIE.EquipmentChecks.CheckEquipmentFile(String file)
   à FLScanIE.EquipmentChecks.CheckEquipmentFolder()
   à FLScanIE.Checker.RunCheck(CheckDelegate check, String name)

(same)

Code:
[error] An error happend while checking fonts 'La référence d'objet n'est pas définie à une instance d'un objet.'   à FLScanIE.FontChecks.CheckFontFolder()
   à FLScanIE.Checker.RunCheck(CheckDelegate check, String name)

(same

Other than that, the other errors I have seem to be real errors, or it tells me where to look for something strange.
The report is maybe a little difficult to understand for non-english and non-freelancer-gurus people (like me), but it's a very good work...

Thank you

Posted on: 2012/3/6 22:32
Top
Topic | Forum


Re: Continuously unable to connect to a Freelancer Server

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
You could try to move the folder or reinstall it outside of Program Files or Program Files (x86). Right are a little strange sometimes inside these 2 folders.

You could try a malware scan with MalwareBytes AntiMalware (free for this use).

Could you try to connect from someone else web connection, to check if your problem is OS/soft or network related ?

Posted on: 2012/3/4 0:50
Top
Topic | Forum


Re: Angels Fall First

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
Wow... It seems really good.... and very beautiful...

Posted on: 2012/3/4 0:46
Top
Topic | Forum


Re: Freelancer Mod Studio - 0.9.9 B2

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
Hi, it's very good news you give us !!!
The only thing I would dream to see is something to help stations modular elements positionning. Designing good looking complexes stations is really hard... and just rotating it several degrees is even more difficult xD

But anyways, thank you for this tool !

Posted on: 2012/3/3 3:30
Top
Topic | Forum


Re: My volume/mass equation : where is the flaw ?

Joined:
2012/2/23 13:01
From France
Group:
Registered Users
Posts: 26
Offline
about the nudge_force :
it has also something to do with docking capabilities. A too low nudge_force breaks the docking sequence.
In Startrader's calculation, I read nudge_force = mass * 3
In mine, nudge_force = max_force ( = mass * 9.81 * Gforce) but mass = ~ 10x Startrader's, and docking seems ok. I didn't test some collision as I wasn't aware of this force translation in collisions (and my COLLISION_DAMAGE_FACTOR = 10000, so I don't really have collision issues with fighters ) .

I also understand that nudge_force has something to do with object avoidance (like in asteroids fields), but I fail to see the mechanic behind it.

Posted on: 2012/2/29 21:39

Edited by ColdFire on 2012/2/29 21:54:46
Edited by ColdFire on 2012/2/29 21:56:59
Top
Topic | Forum



Top Top
(1) 2 »



[Advanced Search]